summaryrefslogtreecommitdiff
path: root/gr-shd/apps/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau2011-10-24 16:32:22 -0400
committerTom Rondeau2011-10-24 16:32:22 -0400
commit50c1e2e35b8ede2798753700a92091c0cb5f0267 (patch)
treed36c54b7e1a2dfb062a634c19725b849451c7a00 /gr-shd/apps/CMakeLists.txt
parente9f4580047977cd319d1991060e2d78f15f27f8f (diff)
downloadgnuradio-50c1e2e35b8ede2798753700a92091c0cb5f0267.tar.gz
gnuradio-50c1e2e35b8ede2798753700a92091c0cb5f0267.tar.bz2
gnuradio-50c1e2e35b8ede2798753700a92091c0cb5f0267.zip
shd: adding gr-shd to cmake build structure. Adding missed app to autotools build.
Diffstat (limited to 'gr-shd/apps/CMakeLists.txt')
-rw-r--r--gr-shd/apps/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/gr-shd/apps/CMakeLists.txt b/gr-shd/apps/CMakeLists.txt
new file mode 100644
index 000000000..3930abb57
--- /dev/null
+++ b/gr-shd/apps/CMakeLists.txt
@@ -0,0 +1,32 @@
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+include(GrPython)
+
+########################################################################
+# Install some shd apps
+########################################################################
+GR_PYTHON_INSTALL(
+ PROGRAMS
+ shd_fft.py
+ shd_rx_cfile.py
+ shd_siggen.py
+ DESTINATION ${GR_RUNTIME_DIR}
+ COMPONENT "shd_python"
+)