summaryrefslogtreecommitdiff
path: root/gr-sbhs/python/CMakeLists.txt
diff options
context:
space:
mode:
authormanojgudi2013-12-24 21:07:36 +0530
committermanojgudi2013-12-24 21:07:36 +0530
commit576936961996253c5a7ea27b63e5bb2ce0bb01aa (patch)
treeb7b92b6025a04317ff7972e3a087b278468209a8 /gr-sbhs/python/CMakeLists.txt
parentda744ab20441967db5bc7885fcd5224f7fd75100 (diff)
downloadgnuradio-576936961996253c5a7ea27b63e5bb2ce0bb01aa.tar.gz
gnuradio-576936961996253c5a7ea27b63e5bb2ce0bb01aa.tar.bz2
gnuradio-576936961996253c5a7ea27b63e5bb2ce0bb01aa.zip
Aded SBHS block
Diffstat (limited to 'gr-sbhs/python/CMakeLists.txt')
-rw-r--r--gr-sbhs/python/CMakeLists.txt94
1 files changed, 94 insertions, 0 deletions
diff --git a/gr-sbhs/python/CMakeLists.txt b/gr-sbhs/python/CMakeLists.txt
new file mode 100644
index 000000000..4c03fb698
--- /dev/null
+++ b/gr-sbhs/python/CMakeLists.txt
@@ -0,0 +1,94 @@
+# Copyright 2012 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+include(GrPython)
+
+GR_PYTHON_INSTALL(
+ FILES
+ __init__.py
+ DESTINATION ${GR_PYTHON_DIR}/gnuradio/sbhs
+ COMPONENT "sbhs_python"
+)
+
+### SBHS BLOCKS ###
+GR_PYTHON_INSTALL(
+ FILES
+ sbhs.py
+ DESTINATION ${GR_PYTHON_DIR}/gnuradio/sbhs
+ COMPONENT "sbhs_python"
+)
+
+
+GR_PYTHON_INSTALL(
+ FILES
+ scan_machines.py
+ DESTINATION ${GR_PYTHON_DIR}/gnuradio/sbhs
+ COMPONENT "sbhs_python"
+)
+
+GR_PYTHON_INSTALL(
+ FILES
+ gr_sbhs.py
+ DESTINATION ${GR_PYTHON_DIR}/gnuradio/sbhs
+ COMPONENT "sbhs_python"
+)
+
+### SBHS CONTROLLER BLOCKS ###
+GR_PYTHON_INSTALL(
+ FILES
+ que.py
+ DESTINATION ${GR_PYTHON_DIR}/gnuradio/sbhs
+ COMPONENT "sbhs_python"
+)
+
+GR_PYTHON_INSTALL(
+ FILES
+ gr_controller.py
+ DESTINATION ${GR_PYTHON_DIR}/gnuradio/sbhs
+ COMPONENT "sbhs_python"
+)
+
+GR_PYTHON_INSTALL(
+ FILES
+ dsim_sci.py
+ DESTINATION ${GR_PYTHON_DIR}/gnuradio/sbhs
+ COMPONENT "sbhs_python"
+)
+
+
+
+
+########################################################################
+# Handle the unit tests
+########################################################################
+if(ENABLE_TESTING)
+
+list(APPEND GR_TEST_PYTHON_DIRS
+ ${CMAKE_BINARY_DIR}/gr-sbhs/python
+)
+list(APPEND GR_TEST_TARGET_DEPS gnuradio-sbhs)
+
+include(GrTest)
+file(GLOB py_qa_test_files "qa_*.py")
+foreach(py_qa_test_file ${py_qa_test_files})
+ get_filename_component(py_qa_test_name ${py_qa_test_file} NAME_WE)
+ GR_ADD_TEST(${py_qa_test_name} ${PYTHON_EXECUTABLE} ${PYTHON_DASH_B} ${py_qa_test_file})
+endforeach(py_qa_test_file)
+endif(ENABLE_TESTING)