summaryrefslogtreecommitdiff
path: root/gr-run-waveform/configure.ac
diff options
context:
space:
mode:
authorJohnathan Corgan2011-03-16 08:18:30 -0700
committerJohnathan Corgan2011-03-16 08:18:30 -0700
commit4cd06fadac972d4cac559c15488bc39823063afe (patch)
tree6fe57896bc216d8c9e672194f2e4e0e75aedb645 /gr-run-waveform/configure.ac
parent4ad736e21f45f64fd616bb53f54e45e1c63e7330 (diff)
parent1d70ed2bd928d52a383e688949cc7f747dd584fa (diff)
downloadgnuradio-4cd06fadac972d4cac559c15488bc39823063afe.tar.gz
gnuradio-4cd06fadac972d4cac559c15488bc39823063afe.tar.bz2
gnuradio-4cd06fadac972d4cac559c15488bc39823063afe.zip
Merge remote branch 'gnuradio/next'
* gnuradio/next: (806 commits) gruel: added missing ignores gruel: fixed swig interface file to dereference pmt_t. qtgui: fix distcheck error gruel: fixing structure. Passes make check. gruel: SWIGing Gruel into Python to access PMTs. gnuradio-examples: add C++ audio examples using new gr-audio created gruel/attributes.h to house compiler specific attribute macros audio: remove obsoleted individual top-level components gr-audio: added README and default config fix volk: simplify the get new method for the aligned pool grc: moved all usrp1 and usrp2 stuff out of grc and into gr-usrp*/grc grc: swap store the subprocess object rather than the pid when executing qtgui: removed python directory that was added, never used uhd: use %ignore to hide warnings and fix errors Added/updated ignore files. Fixing gr_filter_design program to import from gnuradio Python package. audio: high prio for platform specific audio osx audio: added windows and osx audio source files audio: added config checks for other audios, added jack and port audio: make prefs look like old audio, removed old audio.py ...
Diffstat (limited to 'gr-run-waveform/configure.ac')
-rw-r--r--gr-run-waveform/configure.ac58
1 files changed, 58 insertions, 0 deletions
diff --git a/gr-run-waveform/configure.ac b/gr-run-waveform/configure.ac
new file mode 100644
index 000000000..288c7bd1d
--- /dev/null
+++ b/gr-run-waveform/configure.ac
@@ -0,0 +1,58 @@
+dnl
+dnl Copyright 2004,2005,2007,2008,2009 Free Software Foundation, Inc.
+dnl
+dnl This file is part of GNU Radio
+dnl
+dnl GNU Radio is free software; you can redistribute it and/or modify
+dnl it under the terms of the GNU General Public License as published by
+dnl the Free Software Foundation; either version 3, or (at your option)
+dnl any later version.
+dnl
+dnl GNU Radio is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+dnl GNU General Public License for more details.
+dnl
+dnl You should have received a copy of the GNU General Public License
+dnl along with GNU Radio; see the file COPYING. If not, write to
+dnl the Free Software Foundation, Inc., 51 Franklin Street,
+dnl Boston, MA 02110-1301, USA.
+dnl
+
+AC_INIT
+AC_PREREQ(2.57)
+AC_CONFIG_AUX_DIR([.])
+
+AC_CONFIG_HEADERS([grconfig.h])
+AC_CONFIG_MACRO_DIR(config)
+AC_CONFIG_SRCDIR(gr-run-waveform-binary.cc)
+AM_INIT_AUTOMAKE("gr-run-waveform", "0.1")
+
+AC_CANONICAL_BUILD
+AC_CANONICAL_HOST
+dnl AC_CANONICAL_TARGET
+
+dnl Find the the C++ compiler
+AC_PROG_CXX
+AM_PROG_CC_C_O
+AC_PROG_LN_S
+
+GR_LIB64 dnl check for lib64 suffix after choosing compilers
+
+dnl Checks for standard header files.
+AC_HEADER_STDC
+
+dnl Get the paths to the Guile headers and library
+GUILE_DEVEL
+
+AC_PATH_PROG(PYTHON, python)
+AC_SUBST(PYTHON)
+
+AC_CONFIG_FILES([\
+ Makefile \
+ config/Makefile \
+ ])
+
+AC_OUTPUT
+
+echo "Configured gr-run-waveform release $RELEASE for build."