summaryrefslogtreecommitdiff
path: root/gr-run-waveform/Makefile.am
diff options
context:
space:
mode:
authorRob Savoye2010-11-25 11:27:36 -0700
committerRob Savoye2010-11-25 11:27:36 -0700
commitc31f12f2dee7b42d327f85bbc5a9830735d05ec6 (patch)
tree98486a03140f00c70bb3f36b64c1073927f73fd6 /gr-run-waveform/Makefile.am
parent99cb6144a82b88209af2d613e9636449038fcee3 (diff)
downloadgnuradio-c31f12f2dee7b42d327f85bbc5a9830735d05ec6.tar.gz
gnuradio-c31f12f2dee7b42d327f85bbc5a9830735d05ec6.tar.bz2
gnuradio-c31f12f2dee7b42d327f85bbc5a9830735d05ec6.zip
add initial (no guile yet standalone app)
Diffstat (limited to 'gr-run-waveform/Makefile.am')
-rw-r--r--gr-run-waveform/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/gr-run-waveform/Makefile.am b/gr-run-waveform/Makefile.am
new file mode 100644
index 000000000..de820ee48
--- /dev/null
+++ b/gr-run-waveform/Makefile.am
@@ -0,0 +1,31 @@
+#
+# Copyright 2004,2008,2009 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+ACLOCAL_AMFLAGS = -I config
+DIST_SUBDIRS = config
+
+bin_PROGRAMS = run_waveform
+
+run_waveform_SOURCES = run_waveform.cc
+run_waveform_CPPFLAGS = $(GUILE_CFLAGS)
+run_waveform_LDADD = $(GUILE_LIBS)
+
+DISTCLEANFILES = gr-run-waveform.tar.gz