summaryrefslogtreecommitdiff
path: root/gr-run-waveform/Makefile.am
diff options
context:
space:
mode:
authorEric Blossom2010-12-03 14:32:07 -0800
committerEric Blossom2010-12-03 14:32:07 -0800
commit6f1a20284530b20ee3e318cd2fc6724e65b96a14 (patch)
tree491b4937cbdff038ebe631c5df973e417c794c28 /gr-run-waveform/Makefile.am
parentcd8a20ef121a9d07163b420020ba50012fb1a5e4 (diff)
downloadgnuradio-6f1a20284530b20ee3e318cd2fc6724e65b96a14.tar.gz
gnuradio-6f1a20284530b20ee3e318cd2fc6724e65b96a14.tar.bz2
gnuradio-6f1a20284530b20ee3e318cd2fc6724e65b96a14.zip
Rename run_waveform.cc gr-run-waveform.cc
Diffstat (limited to 'gr-run-waveform/Makefile.am')
-rw-r--r--gr-run-waveform/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/gr-run-waveform/Makefile.am b/gr-run-waveform/Makefile.am
index 4c9c7af19..1c8305e1e 100644
--- a/gr-run-waveform/Makefile.am
+++ b/gr-run-waveform/Makefile.am
@@ -27,7 +27,7 @@ EXTRA_DIST = gen-xyzzy \
guile/simple.scm
# build the standalone waveform application
-bin_PROGRAMS = run_waveform
+bin_PROGRAMS = gr-run-waveform
# Rather than build a library, we just use a variable so the same code
# can be used in test cases, as well as the run-waveform application.
@@ -61,16 +61,16 @@ test_waveform_DEPENDENCIES = $(BUILT_SOURCES)
noinst_HEADERS = xyzzy.h
# The standalone waveform application
-run_waveform_SOURCES = run_waveform.cc $(SRCS)
-run_waveform_CPPFLAGS = $(GUILE_CFLAGS) \
+gr_run_waveform_SOURCES = gr-run-waveform.cc $(SRCS)
+gr_run_waveform_CPPFLAGS = $(GUILE_CFLAGS) \
-DSRCDIR=\"$(srcdir)\" \
-DPKGLIBDIR=\"$(pkglibdir)\" \
-DDATAROOTDIR=\"$(datarootdir)\"
# Uncommenting this force make to statically link in the guile library.
# Note that this will fail to link it you don't have libguile.a.
# run_waveform_LDFLAGS = -static
-run_waveform_LDADD = $(GUILE_LIBS)
-run_waveform_DEPENDENCIES = $(BUILT_SOURCES)
+gr_run_waveform_LDADD = $(GUILE_LIBS)
+gr_run_waveform_DEPENDENCIES = $(BUILT_SOURCES)
DISTCLEANFILES = gr-run-waveform.tar.gz libpath.h filesystem.dat