summaryrefslogtreecommitdiff
path: root/gr-qtgui/swig/Makefile.am
diff options
context:
space:
mode:
authorJohnathan Corgan2012-04-07 19:32:10 -0700
committerJohnathan Corgan2012-04-07 19:32:10 -0700
commit9bef26c9271a7b9253075bda3c1fc7c8078c0343 (patch)
treea6c1329bb902c95c8ab9970f38ec5fb46d79167c /gr-qtgui/swig/Makefile.am
parentf621a52f779381cfe550b4278b83e701a747944c (diff)
parentef72dc714840dfb8fe3f918dda243f74453b6cc7 (diff)
downloadgnuradio-9bef26c9271a7b9253075bda3c1fc7c8078c0343.tar.gz
gnuradio-9bef26c9271a7b9253075bda3c1fc7c8078c0343.tar.bz2
gnuradio-9bef26c9271a7b9253075bda3c1fc7c8078c0343.zip
Merge branch 'next'
Diffstat (limited to 'gr-qtgui/swig/Makefile.am')
-rw-r--r--gr-qtgui/swig/Makefile.am73
1 files changed, 0 insertions, 73 deletions
diff --git a/gr-qtgui/swig/Makefile.am b/gr-qtgui/swig/Makefile.am
deleted file mode 100644
index cda2620b5..000000000
--- a/gr-qtgui/swig/Makefile.am
+++ /dev/null
@@ -1,73 +0,0 @@
-#
-# Copyright 2004-2006,2008-2011 Free Software Foundation, Inc.
-#
-# This file is part of GNU Radio
-#
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-#
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING. If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-#
-
-include $(top_srcdir)/Makefile.common
-include $(top_srcdir)/Makefile.swig
-
-TESTS =
-EXTRA_DIST += $(nobase_guile_DATA)
-
-AM_CPPFLAGS = \
- -I$(top_srcdir)/gr-qtgui/lib \
- -I$(top_builddir)/gr-qtgui/lib \
- $(STD_DEFINES_AND_INCLUDES) \
- $(PYTHON_CPPFLAGS) \
- $(QT_INCLUDES) \
- $(GR_QTGUI_INCLUDES) \
- $(WITH_INCLUDES)
-
-##############################
-# SWIG interface and library
-
-TOP_SWIG_DOC_IFILES = \
- qtgui_swig_doc.i
-
-TOP_SWIG_IFILES = \
- $(TOP_SWIG_DOC_IFILES) \
- qtgui_swig.i
-
-BUILT_SOURCES += \
- $(TOP_SWIG_DOC_IFILES)
-
-EXTRA_DIST += \
- $(TOP_SWIG_DOC_IFILES)
-
-$(TOP_SWIG_DOC_IFILES):
- `echo "" > $@`
-
-# Install so that they end up available as:
-# import gnuradio.qtgui
-# This ends up at:
-# ${prefix}/lib/python${python_version}/site-packages/gnuradio/qtgui
-qtgui_swig_pythondir_category = \
- gnuradio/qtgui
-
-# additional libraries for linking with the SWIG-generated library
-qtgui_swig_la_swig_libadd = \
- $(abs_top_builddir)/gr-qtgui/lib/libgnuradio-qtgui.la
-
-# additional SWIG files to be installed
-qtgui_swig_swiginclude_headers = \
- qtgui_sink_c.i \
- qtgui_sink_f.i \
- qtgui_time_sink_c.i \
- qtgui_time_sink_f.i \
- $(TOP_SWIG_DOC_IFILES)