summaryrefslogtreecommitdiff
path: root/gr-qtgui/src/lib/Makefile.am
diff options
context:
space:
mode:
authorJohnathan Corgan2010-06-13 14:18:27 -0700
committerJohnathan Corgan2010-06-13 14:18:27 -0700
commite19404263e08fce0259069a311e321ed5277e16d (patch)
tree09bb3d667378bf63e51ee4ff85c205fde9286693 /gr-qtgui/src/lib/Makefile.am
parentd4766ba22b22a3f7730f8bcb32cd0d71422f96a8 (diff)
parentf0b3dab8125979630651e8d016be296ae607c641 (diff)
downloadgnuradio-e19404263e08fce0259069a311e321ed5277e16d.tar.gz
gnuradio-e19404263e08fce0259069a311e321ed5277e16d.tar.bz2
gnuradio-e19404263e08fce0259069a311e321ed5277e16d.zip
Merge branch 'master' into next
* master: Fixes gr-qtgui make distcheck failure when QT is not installed.
Diffstat (limited to 'gr-qtgui/src/lib/Makefile.am')
-rw-r--r--gr-qtgui/src/lib/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/gr-qtgui/src/lib/Makefile.am b/gr-qtgui/src/lib/Makefile.am
index 26b97d1d4..6d4a91257 100644
--- a/gr-qtgui/src/lib/Makefile.am
+++ b/gr-qtgui/src/lib/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2008,2009 Free Software Foundation, Inc.
+# Copyright 2008,2009,2010 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -54,7 +54,6 @@ libgnuradio_qtgui_la_SOURCES = \
SpectrumGUIClass.cc \
spectrumUpdateEvents.cc \
plot_waterfall.cc \
- $(QMAKE_SOURCES) \
qtgui_sink_c.cc \
qtgui_sink_f.cc
@@ -75,6 +74,8 @@ grinclude_HEADERS = \
qtgui_sink_c.h \
qtgui_sink_f.h
+nodist_libqtsrc_la_SOURCES = $(QMAKE_SOURCES)
+
%_moc.cc : %.h
$(QT_MOC_EXEC) -DQT_SHARED -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_CORE_LIB -p $(srcdir) $< -o $@