summaryrefslogtreecommitdiff
path: root/gr-qtgui/src/lib/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2009-05-27 01:54:41 +0000
committerjcorgan2009-05-27 01:54:41 +0000
commit40b8a57d69b4b85f207fb0408347c210e23202cc (patch)
tree8d1e3bbc9159bdd0de98bb897432abd81563dbca /gr-qtgui/src/lib/Makefile.am
parente3cd8f7d59aad0ffd51c417b2623ab02588fdb08 (diff)
downloadgnuradio-40b8a57d69b4b85f207fb0408347c210e23202cc.tar.gz
gnuradio-40b8a57d69b4b85f207fb0408347c210e23202cc.tar.bz2
gnuradio-40b8a57d69b4b85f207fb0408347c210e23202cc.zip
Merged r11123:11148 from jcorgan/np into trunk.
Adds --enable-python option to configure (defaults to yes). Using --disable-python or --enable-python=no will cause only C++ API targets to be created and installed. Several new shared libraries are now created. Where in the past, the C++ objects of the actual gnuradio blocks that were in a component were hidden inside their corresponding Python extension modules, these are now split out into a libgnuradio-foo.so library, and the _foo.so Python module is linked to that. This has been the way several top- level components have operated for some time, such as gr-audio-alsa and gr-usrp and gr-usrp2. This changeset applies that pattern to all components. C++ API users can use pkg-config to discover the cflags and libs parameters needed to include and link against these libraries. These components have not been tested: gr-comedi gr-audio-osx gr-audio-windows Passes distcheck. git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@11150 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gr-qtgui/src/lib/Makefile.am')
-rw-r--r--gr-qtgui/src/lib/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/gr-qtgui/src/lib/Makefile.am b/gr-qtgui/src/lib/Makefile.am
index 6543a71ce..290af1dd3 100644
--- a/gr-qtgui/src/lib/Makefile.am
+++ b/gr-qtgui/src/lib/Makefile.am
@@ -39,6 +39,8 @@ endif
EXTRA_DIST = spectrumdisplayform.ui
+BUILT_SOURCES = $(QMAKE_SOURCES)
+
# Build the normal library for C++ apps to link against
lib_LTLIBRARIES = libgnuradio-qtgui.la
@@ -97,6 +99,7 @@ libgnuradio_qtgui_la_LIBADD = \
-lstdc++ \
$(QT_LIBS)
+if PYTHON
##############################
# SWIG interface and library
@@ -117,9 +120,9 @@ qtgui_la_swig_libadd = \
include $(top_srcdir)/Makefile.swig
# add some of the variables generated inside the Makefile.swig.gen
-BUILT_SOURCES = \
- $(QMAKE_SOURCES) \
+BUILT_SOURCES += \
$(swig_built_sources)
# Do not distribute the output of SWIG
no_dist_files = $(swig_built_sources)
+endif