summaryrefslogtreecommitdiff
path: root/gr-qtgui/src/lib/Makefile.am
diff options
context:
space:
mode:
authorJohnathan Corgan2009-10-22 11:12:42 -0700
committerJohnathan Corgan2009-10-22 11:12:42 -0700
commit0b9828e8cad48722c22979587db861e1806a7fb7 (patch)
treeb3f4b6db431918a24923f7f669ef9a49a75e1292 /gr-qtgui/src/lib/Makefile.am
parent8e003a402af2993f978620741fdf195ac9bf7834 (diff)
downloadgnuradio-0b9828e8cad48722c22979587db861e1806a7fb7.tar.gz
gnuradio-0b9828e8cad48722c22979587db861e1806a7fb7.tar.bz2
gnuradio-0b9828e8cad48722c22979587db861e1806a7fb7.zip
Don't distribute generated files in gr-qtgui
The output of the moc compiler will contain generated paths which are only valid on the system at compilation time. Instead, let these get regenerated on the user's system. The moc compiler is part of libqt4-dev, which is already a build dependency.
Diffstat (limited to 'gr-qtgui/src/lib/Makefile.am')
-rw-r--r--gr-qtgui/src/lib/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/gr-qtgui/src/lib/Makefile.am b/gr-qtgui/src/lib/Makefile.am
index 6c90c31f0..814bee136 100644
--- a/gr-qtgui/src/lib/Makefile.am
+++ b/gr-qtgui/src/lib/Makefile.am
@@ -112,7 +112,8 @@ include $(top_srcdir)/Makefile.swig
# add some of the variables generated inside the Makefile.swig.gen
BUILT_SOURCES += \
$(swig_built_sources)
-
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
endif
+
+# Do not distribute built sources, they may contain generated paths
+# which are invalid on other systems
+no_dist_files = $(BUILT_SOURCES)