summaryrefslogtreecommitdiff
path: root/gr-qtgui/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael L Dickens2013-01-01 21:42:23 -0500
committerMichael L Dickens2013-01-01 21:42:23 -0500
commite788c523d4f8de3efd64a64f148ac1bf25ea032d (patch)
treec6c243c3770f65a71cb9f3990dd2dd8c27bdb422 /gr-qtgui/CMakeLists.txt
parent053d729bcaa6e88791ae21f4c29f3df631aaab65 (diff)
downloadgnuradio-e788c523d4f8de3efd64a64f148ac1bf25ea032d.tar.gz
gnuradio-e788c523d4f8de3efd64a64f148ac1bf25ea032d.tar.bz2
gnuradio-e788c523d4f8de3efd64a64f148ac1bf25ea032d.zip
Tweak INCLUDE dirs such that INCLUDE_DIRECTORIES and LINK_DIRECTORIES are ordered as: internal build and source for this component, other components (internal build and source, or already installed), non-project non-system dependencies (e.g., Qt, Boost, Python), system dependencies (e.g., CoreAudio).
Diffstat (limited to 'gr-qtgui/CMakeLists.txt')
-rw-r--r--gr-qtgui/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/gr-qtgui/CMakeLists.txt b/gr-qtgui/CMakeLists.txt
index f6260bc7e..f25564bfc 100644
--- a/gr-qtgui/CMakeLists.txt
+++ b/gr-qtgui/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright 2010-2011 Free Software Foundation, Inc.
+# Copyright 2010-2011,2013 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -64,7 +64,8 @@ SET(GR_PKG_QTGUI_EXAMPLES_DIR ${GR_PKG_DATA_DIR}/examples/qt-gui)
########################################################################
if(ENABLE_GR_QTGUI)
-include(${QT_USE_FILE}) #sets up the environment
+# populate the environment with QT variables
+include(GrUseQt4)
########################################################################
# Setup CPack components