summaryrefslogtreecommitdiff
path: root/gr-pager/swig/Makefile.am
diff options
context:
space:
mode:
authorTom Rondeau2011-12-04 11:10:13 -0500
committerTom Rondeau2011-12-04 11:10:13 -0500
commitfe2e6f8054ed8c6a19fe893553a0d05ce855179e (patch)
treebdce8a051d53a33872479233dfe6171d8763732f /gr-pager/swig/Makefile.am
parent2f48e2a60e76072e5436dde860cd602c3882ce5c (diff)
downloadgnuradio-fe2e6f8054ed8c6a19fe893553a0d05ce855179e.tar.gz
gnuradio-fe2e6f8054ed8c6a19fe893553a0d05ce855179e.tar.bz2
gnuradio-fe2e6f8054ed8c6a19fe893553a0d05ce855179e.zip
docs: better install of swig docs .i files since we actually have a variable to take care of it already.
Diffstat (limited to 'gr-pager/swig/Makefile.am')
-rw-r--r--gr-pager/swig/Makefile.am17
1 files changed, 9 insertions, 8 deletions
diff --git a/gr-pager/swig/Makefile.am b/gr-pager/swig/Makefile.am
index 4be40a6b0..bf0b095ba 100644
--- a/gr-pager/swig/Makefile.am
+++ b/gr-pager/swig/Makefile.am
@@ -50,12 +50,12 @@ TOP_SWIG_DOC_IFILES = \
BUILT_SOURCES += \
$(TOP_SWIG_DOC_IFILES)
+EXTRA_DIST += \
+ $(TOP_SWIG_DOC_IFILES)
+
$(TOP_SWIG_DOC_IFILES):
`echo "" > $@`
-install-data-local:
- cp -p $(TOP_SWIG_DOC_IFILES) $(swigincludedir)
-
# Install so that they end up available as:
# import gnuradio.pager
# This ends up at:
@@ -69,11 +69,12 @@ pager_swig_la_swig_libadd = \
# additional SWIG files to be installed
pager_swig_swiginclude_headers = \
- pager_flex_deinterleave.i \
- pager_flex_frame.i \
- pager_flex_parse.i \
- pager_flex_sync.i \
- pager_slicer_fb.i
+ pager_flex_deinterleave.i \
+ pager_flex_frame.i \
+ pager_flex_parse.i \
+ pager_flex_sync.i \
+ pager_slicer_fb.i \
+ $(TOP_SWIG_DOC_IFILES)
if GUILE
TESTS += run_guile_tests