summaryrefslogtreecommitdiff
path: root/gr-noaa/Makefile.am
diff options
context:
space:
mode:
authorJohnathan Corgan2009-08-15 12:30:45 -0700
committerJohnathan Corgan2009-09-20 09:39:27 -0700
commitb6101982e270948b4a3185ee745ed76bb8661552 (patch)
treef3b1b8e79e35173d98c2b91c3035f711c16af499 /gr-noaa/Makefile.am
parent7d8dd5e122e0201d96410eec6549b903881f8b3a (diff)
downloadgnuradio-b6101982e270948b4a3185ee745ed76bb8661552.tar.gz
gnuradio-b6101982e270948b4a3185ee745ed76bb8661552.tar.bz2
gnuradio-b6101982e270948b4a3185ee745ed76bb8661552.zip
Created new gr-noaa top-level component.
Initial work: - Carrier recovery/mixer PLL block - Start of POES grc pipeline, recovers Manchester symbols only - Start of GOES grc pipeline, recovers BPSK symbols only
Diffstat (limited to 'gr-noaa/Makefile.am')
-rw-r--r--gr-noaa/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/gr-noaa/Makefile.am b/gr-noaa/Makefile.am
new file mode 100644
index 000000000..fa03f1088
--- /dev/null
+++ b/gr-noaa/Makefile.am
@@ -0,0 +1,31 @@
+#
+# Copyright 2009 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+SUBDIRS = lib
+
+if PYTHON
+SUBDIRS += swig
+endif
+
+SUBDIRS += grc
+