summaryrefslogtreecommitdiff
path: root/gr-msdd6000/src/Makefile.am
diff options
context:
space:
mode:
authorn4hy2008-07-04 01:26:58 +0000
committern4hy2008-07-04 01:26:58 +0000
commitae0ca251c8384b97ef1ba69a13c02227a57eaa54 (patch)
treeb6c309a320c12f8798878461b83b110e9a6d2578 /gr-msdd6000/src/Makefile.am
parent20615905cd0bf22772740d132be439bcf7ec4d8d (diff)
downloadgnuradio-ae0ca251c8384b97ef1ba69a13c02227a57eaa54.tar.gz
gnuradio-ae0ca251c8384b97ef1ba69a13c02227a57eaa54.tar.bz2
gnuradio-ae0ca251c8384b97ef1ba69a13c02227a57eaa54.zip
cleaning up and putting much better code in. Step 1 of 2
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@8778 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gr-msdd6000/src/Makefile.am')
-rw-r--r--gr-msdd6000/src/Makefile.am82
1 files changed, 81 insertions, 1 deletions
diff --git a/gr-msdd6000/src/Makefile.am b/gr-msdd6000/src/Makefile.am
index 923b1c25a..dbf1271ed 100644
--- a/gr-msdd6000/src/Makefile.am
+++ b/gr-msdd6000/src/Makefile.am
@@ -18,5 +18,85 @@
# the Free Software Foundation, Inc., 51 Franklin Street,
# Boston, MA 02110-1301, USA.
#
+CCFLAGS = -g
+include $(top_srcdir)/Makefile.common
-SUBDIRS = lib python
+# Install this stuff so that it ends up as the gnuradio.howto module
+# This usually ends up at:
+# ${prefix}/lib/python${python_version}/site-packages/gnuradio
+
+ourpythondir = $(grpythondir)
+ourlibdir = $(grpyexecdir)
+
+INCLUDES = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS)
+
+SWIGPYTHONARGS = $(SWIGPYTHONFLAGS) $(SWIGGRFLAGS)
+
+ALL_IFILES = \
+ $(LOCAL_IFILES) \
+ $(NON_LOCAL_IFILES)
+
+NON_LOCAL_IFILES = \
+ $(GNURADIO_CORE_INCLUDEDIR)/swig/gnuradio.i
+
+
+LOCAL_IFILES = \
+ $(top_srcdir)/src/msdd/msdd.i
+
+# These files are built by SWIG. The first is the C++ glue.
+# The second is the python wrapper that loads the _howto shared library
+# and knows how to call our extensions.
+
+BUILT_SOURCES = \
+ msdd.cc \
+ msdd.py
+
+# This gets howto.py installed in the right place
+ourpython_PYTHON = \
+ msdd.py
+
+ourlib_LTLIBRARIES = _msdd.la
+
+# These are the source files that go into the shared library
+_msdd_la_SOURCES = \
+ msdd.cc \
+ msdd_source_base.cc \
+ msdd_source_c.cc \
+ msdd_source_simple.cc \
+ msdd_source_s.cc \
+ msdd6000.cc
+
+# magic flag
+_msdd_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
+#-lfftw3 -lfftw3f -lfann
+
+# link the library against some comon swig runtime code and the
+# c++ standard library
+_msdd_la_LIBADD = \
+ $(PYTHON_LDFLAGS) \
+ -lstdc++
+# -L/usr/lib/libfftw3f.so.3.1.2
+
+msdd.cc msdd.py: $(LOCAL_IFILES) $(ALL_IFILES)
+ $(SWIG) $(SWIGPYTHONARGS) -module msdd -o msdd.cc $(LOCAL_IFILES)
+
+# These headers get installed in ${prefix}/include/gnuradio
+grinclude_HEADERS = \
+ msdd_source_base.h \
+ msdd_source_c.h \
+ msdd_source_simple.h \
+ msdd_source_s.h
+
+
+
+# These swig headers get installed in ${prefix}/include/gnuradio/swig
+swiginclude_HEADERS = \
+ $(LOCAL_IFILES)
+
+
+MOSTLYCLEANFILES = $(BUILT_SOURCES) *.pyc
+
+# Don't distribute output of swig
+dist-hook:
+ @for file in $(BUILT_SOURCES); do echo $(RM) $(distdir)/$$file; done
+ @for file in $(BUILT_SOURCES); do $(RM) $(distdir)/$$file; done