summaryrefslogtreecommitdiff
path: root/gr-input/python/CMakeLists.txt
diff options
context:
space:
mode:
authorAshwini2015-03-10 17:23:13 +0530
committerAshwini2015-03-10 17:23:13 +0530
commit92326794e39e1753f5fcb20715c57ea0f537752e (patch)
treee40825f34f4a6402d9acf2fdcf5600dd65ad6f56 /gr-input/python/CMakeLists.txt
parentaf6398eb6e3273c005312939fb6d965f8a50baed (diff)
downloadgnuradio-92326794e39e1753f5fcb20715c57ea0f537752e.tar.gz
gnuradio-92326794e39e1753f5fcb20715c57ea0f537752e.tar.bz2
gnuradio-92326794e39e1753f5fcb20715c57ea0f537752e.zip
Deleted
Diffstat (limited to 'gr-input/python/CMakeLists.txt')
-rw-r--r--gr-input/python/CMakeLists.txt128
1 files changed, 0 insertions, 128 deletions
diff --git a/gr-input/python/CMakeLists.txt b/gr-input/python/CMakeLists.txt
deleted file mode 100644
index 7c73fc59f..000000000
--- a/gr-input/python/CMakeLists.txt
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 2012 Free Software Foundation, Inc.
-#
-# This file is part of GNU Radio
-#
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-#
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING. If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-
-########################################################################
-include(GrPython)
-
-GR_PYTHON_INSTALL(
- FILES
- __init__.py
- DESTINATION ${GR_PYTHON_DIR}/gnuradio/input
- COMPONENT "input_python"
-)
-
-GR_PYTHON_INSTALL(
- FILES
- gr_ramp_source.py
- DESTINATION ${GR_PYTHON_DIR}/gnuradio/input
- COMPONENT "input_python"
-)
-
-GR_PYTHON_INSTALL(
- FILES
- gr_step_source.py
- DESTINATION ${GR_PYTHON_DIR}/gnuradio/input
- COMPONENT "input_python"
-)
-
-GR_PYTHON_INSTALL(
- FILES
- ramp_hierblock.py
- DESTINATION ${GR_PYTHON_DIR}/gnuradio/input
- COMPONENT "input_python"
-)
-
-GR_PYTHON_INSTALL(
- FILES
- step_hierblock.py
- DESTINATION ${GR_PYTHON_DIR}/gnuradio/input
- COMPONENT "input_python"
-)
-
-GR_PYTHON_INSTALL(
- FILES
- Numerator.py
- DESTINATION ${GR_PYTHON_DIR}/gnuradio/input
- COMPONENT "input_python"
-)
-
-
-GR_PYTHON_INSTALL(
- FILES
- Denominator.py
- DESTINATION ${GR_PYTHON_DIR}/gnuradio/input
- COMPONENT "input_python"
-)
-
-
-GR_PYTHON_INSTALL(
- FILES
- Response.py
- DESTINATION ${GR_PYTHON_DIR}/gnuradio/input
- COMPONENT "input_python"
-)
-
-GR_PYTHON_INSTALL(
- FILES
- Roots.py
- DESTINATION ${GR_PYTHON_DIR}/gnuradio/input
- COMPONENT "input_python"
-)
-
-GR_PYTHON_INSTALL(
- FILES
- Calculator.py
- DESTINATION ${GR_PYTHON_DIR}/gnuradio/input
- COMPONENT "input_python"
-)
-
-GR_PYTHON_INSTALL(
- FILES
- plot_sink.py
- DESTINATION ${GR_PYTHON_DIR}/gnuradio/input
- COMPONENT "input_python"
-)
-
-GR_PYTHON_INSTALL(
- FILES
- matplotsink.py
- DESTINATION ${GR_PYTHON_DIR}/gnuradio/input
- COMPONENT "input_python"
-)
-
-
-########################################################################
-# Handle the unit tests
-########################################################################
-if(ENABLE_TESTING)
-
-list(APPEND GR_TEST_PYTHON_DIRS
- ${CMAKE_BINARY_DIR}/gr-input/python
-)
-list(APPEND GR_TEST_TARGET_DEPS gnuradio-input)
-
-include(GrTest)
-
-
-file(GLOB py_qa_test_files "qa_*.py")
-foreach(py_qa_test_file ${py_qa_test_files})
- get_filename_component(py_qa_test_name ${py_qa_test_file} NAME_WE)
- GR_ADD_TEST(${py_qa_test_name} ${PYTHON_EXECUTABLE} ${PYTHON_DASH_B} ${py_qa_test_file})
-endforeach(py_qa_test_file)
-endif(ENABLE_TESTING)