summaryrefslogtreecommitdiff
path: root/gr-howto-write-a-block/src/lib/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2009-08-06 23:21:40 +0000
committerjcorgan2009-08-06 23:21:40 +0000
commit34791dbc3c8ab646b63d8ae6e96972b20fe6fd37 (patch)
treeddb5dd6cc42465709a74eb8e17e8d8ba06300c98 /gr-howto-write-a-block/src/lib/Makefile.am
parent4e843330290a3fd4354d5ab3acc599b7f7465587 (diff)
downloadgnuradio-34791dbc3c8ab646b63d8ae6e96972b20fe6fd37.tar.gz
gnuradio-34791dbc3c8ab646b63d8ae6e96972b20fe6fd37.tar.bz2
gnuradio-34791dbc3c8ab646b63d8ae6e96972b20fe6fd37.zip
howto: adds --disable-python option to gr-howto-write-a-block example.
Signed-off-by: Johnathan Corgan <jcorgan@corganenterprises.com> git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@11542 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gr-howto-write-a-block/src/lib/Makefile.am')
-rw-r--r--gr-howto-write-a-block/src/lib/Makefile.am47
1 files changed, 19 insertions, 28 deletions
diff --git a/gr-howto-write-a-block/src/lib/Makefile.am b/gr-howto-write-a-block/src/lib/Makefile.am
index 5b6d5136a..fa6b439ea 100644
--- a/gr-howto-write-a-block/src/lib/Makefile.am
+++ b/gr-howto-write-a-block/src/lib/Makefile.am
@@ -21,11 +21,27 @@
include $(top_srcdir)/Makefile.common
+###################################
+# howto C++ library
+
# C/C++ headers get installed in ${prefix}/include/gnuradio
grinclude_HEADERS = \
howto_square_ff.h \
howto_square2_ff.h
+lib_LTLIBRARIES = libgnuradio-howto.la
+
+libgnuradio_howto_la_SOURCES = \
+ howto_square_ff.cc \
+ howto_square2_ff.cc
+
+libgnuradio_howto_la_LIBADD = \
+ $(GNURADIO_CORE_LA)
+
+libgnuradio_howto_la_LDFLAGS = \
+ $(NO_UNDEFINED)
+
+if PYTHON
###################################
# SWIG Python interface and library
@@ -39,34 +55,8 @@ TOP_SWIG_IFILES = \
howto_pythondir_category = \
gnuradio
-# additional arguments to the SWIG command
-#howto_la_swig_args = \
-# -g
-
-# additional sources for the SWIG-generated library
-howto_la_swig_sources = \
- howto_square_ff.cc \
- howto_square2_ff.cc
-
-# additional arguments to the SWIG command
-#howto_la_swig_args = \
-# $(SWIG_PYTHON_ARGS)
-
-# additional libraries for linking with the SWIG-generated library
-#howto_la_swig_libadd = \
-# libm.dylib
-
-# additional LD flags for linking the SWIG-generated library
-#howto_la_swig_ldflags = \
-# -L/opt/local/bin
-
-# additional Python files to be installed along with the SWIG-generated one
-#howto_python = \
-# __init__.py
-
-# additional SWIG files to be installed
-#howto_swiginclude_headers = \
-# nothing.i
+howto_la_swig_libadd = \
+ libgnuradio-howto.la
include $(top_srcdir)/Makefile.swig
@@ -75,3 +65,4 @@ BUILT_SOURCES = $(swig_built_sources)
# Do not distribute the output of SWIG
no_dist_files = $(swig_built_sources)
+endif