summaryrefslogtreecommitdiff
path: root/gr-howto-write-a-block/limbo/doc/Makefile.am
diff options
context:
space:
mode:
authorJohnathan Corgan2009-11-03 14:24:43 -0800
committerJohnathan Corgan2009-11-03 14:24:43 -0800
commit0bde79ebad973abdcfa23b4d50261fcee39cc28e (patch)
tree1bcc8ed9a899688afe3afdc93e9bcca87a7047b1 /gr-howto-write-a-block/limbo/doc/Makefile.am
parent3e366411a75b47eff5f76c76beb1f3a47006f6c7 (diff)
parent26d9beb0b51945915798e75ab24051adaa46d083 (diff)
downloadgnuradio-0bde79ebad973abdcfa23b4d50261fcee39cc28e.tar.gz
gnuradio-0bde79ebad973abdcfa23b4d50261fcee39cc28e.tar.bz2
gnuradio-0bde79ebad973abdcfa23b4d50261fcee39cc28e.zip
Merge branch 'wip/howto' of git@gnuradio.org:jcorgan
* 'wip/howto' of git@gnuradio.org:jcorgan: howto: moved osbsolete docs directory into limbo howto: make swig directory use individual .i files howto: reorganized directory structure howto: implement dynamic versioning howto: update m4 files to match latest master howto: updated INSTALL, fixed mode of config.*
Diffstat (limited to 'gr-howto-write-a-block/limbo/doc/Makefile.am')
-rw-r--r--gr-howto-write-a-block/limbo/doc/Makefile.am81
1 files changed, 81 insertions, 0 deletions
diff --git a/gr-howto-write-a-block/limbo/doc/Makefile.am b/gr-howto-write-a-block/limbo/doc/Makefile.am
new file mode 100644
index 000000000..5f58a21e9
--- /dev/null
+++ b/gr-howto-write-a-block/limbo/doc/Makefile.am
@@ -0,0 +1,81 @@
+#
+# Copyright 2004,2005,2007 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+TARGETS = howto-write-a-block.html
+
+# To avoid build problems for folks who don't have xmlto installed, we
+# don't build the docs by default.
+
+# html: $(TARGETS)
+all: $(TARGETS)
+
+
+EXTRA_DIST = \
+ README \
+ howto-write-a-block.xml \
+ howto_1.i \
+ make_numbered_listing.py \
+ qa_howto_1.py \
+ src_lib_Makefile_1.am \
+ src_lib_Makefile_2.am
+
+
+BUILT_XML_FILES = \
+ gr_block.h.xml \
+ howto_1.i.xml \
+ howto_square_ff.cc.xml \
+ howto_square_ff.h.xml \
+ howto_square2_ff.cc.xml \
+ howto_square2_ff.h.xml \
+ qa_howto_1.py.xml \
+ src_lib_Makefile_1.am.xml \
+ src_lib_Makefile_2.am.xml
+
+
+howto-write-a-block.html : howto-write-a-block.xml $(BUILT_XML_FILES)
+
+
+gr_block.h.xml: $(GNURADIO_CORE_INCLUDEDIR)/gr_block.h make_numbered_listing.py
+ $(PYTHON) ./make_numbered_listing.py $(GNURADIO_CORE_INCLUDEDIR)/gr_block.h
+
+howto_square_ff.cc.xml: $(top_srcdir)/src/lib/howto_square_ff.cc make_numbered_listing.py
+ $(PYTHON) ./make_numbered_listing.py $(top_srcdir)/src/lib/howto_square_ff.cc
+
+howto_square_ff.h.xml: $(top_srcdir)/src/lib/howto_square_ff.h make_numbered_listing.py
+ $(PYTHON) ./make_numbered_listing.py $(top_srcdir)/src/lib/howto_square_ff.h
+
+howto_square2_ff.cc.xml: $(top_srcdir)/src/lib/howto_square2_ff.cc make_numbered_listing.py
+ $(PYTHON) ./make_numbered_listing.py $(top_srcdir)/src/lib/howto_square2_ff.cc
+
+howto_square2_ff.h.xml: $(top_srcdir)/src/lib/howto_square2_ff.h make_numbered_listing.py
+ $(PYTHON) ./make_numbered_listing.py $(top_srcdir)/src/lib/howto_square2_ff.h
+
+
+# ----------------------------------------------------------------
+
+clean:
+ -${RM} -f $(TARGETS) $(BUILT_XML_FILES)
+
+%.html : %.xml
+ xmlto html-nochunks $<
+
+%.xml : % make_numbered_listing.py
+ $(PYTHON) ./make_numbered_listing.py $<