summaryrefslogtreecommitdiff
path: root/gr-howto-write-a-block/lib/Makefile.am
diff options
context:
space:
mode:
authorJohnathan Corgan2009-11-13 11:28:58 -0800
committerJohnathan Corgan2009-11-13 11:28:58 -0800
commitbaac64c9f1ff5fd5eaf9c24159d56567fd4c6fca (patch)
tree33ed69583ffd3b1b0ec630d3383ca0935719857f /gr-howto-write-a-block/lib/Makefile.am
parent5787a2c4f9dbaca94f7b2e7d43f677a64209e5f7 (diff)
parentdf8b099a4b96ad41369a750d48a8576b95ecf454 (diff)
downloadgnuradio-baac64c9f1ff5fd5eaf9c24159d56567fd4c6fca.tar.gz
gnuradio-baac64c9f1ff5fd5eaf9c24159d56567fd4c6fca.tar.bz2
gnuradio-baac64c9f1ff5fd5eaf9c24159d56567fd4c6fca.zip
Merge branch 'wip/howto' of git@gnuradio.org:jcorgan
* 'wip/howto' of git@gnuradio.org:jcorgan: howto: cleanup for merge howto: add README.hacking howto: added howto application howto: add GRC wrappers to squaring blocks howto: move limbo'd docs into toplevel doc dir for preservation howto: create howto_swig.*, use constructed Python namespace howto: adds C++ QA code
Diffstat (limited to 'gr-howto-write-a-block/lib/Makefile.am')
-rw-r--r--gr-howto-write-a-block/lib/Makefile.am42
1 files changed, 40 insertions, 2 deletions
diff --git a/gr-howto-write-a-block/lib/Makefile.am b/gr-howto-write-a-block/lib/Makefile.am
index e553c193d..336cb8a20 100644
--- a/gr-howto-write-a-block/lib/Makefile.am
+++ b/gr-howto-write-a-block/lib/Makefile.am
@@ -21,8 +21,12 @@
include $(top_srcdir)/Makefile.common
-###################################
-# howto C++ library
+# list of programs run by "make check" and "make distcheck"
+TESTS = test_all
+
+# ----------------------------------------------------------------
+# howto C++ library: libgnuradio-howto.so
+# ----------------------------------------------------------------
# C/C++ headers get installed in ${prefix}/include/gnuradio
grinclude_HEADERS = \
@@ -40,3 +44,37 @@ libgnuradio_howto_la_LIBADD = \
libgnuradio_howto_la_LDFLAGS = \
$(NO_UNDEFINED)
+
+# ----------------------------------------------------------------
+# howto C++ QA library: libgnuradio-howto-qa.so (not installed)
+# ----------------------------------------------------------------
+
+noinst_LTLIBRARIES = libgnuradio-howto-qa.la
+
+libgnuradio_howto_qa_la_SOURCES = \
+ qa_howto.cc \
+ qa_howto_square_ff.cc \
+ qa_howto_square2_ff.cc
+
+libgnuradio_howto_qa_la_LDFLAGS = $(NO_UNDEFINED) -version-info 0:0:0
+
+libgnuradio_howto_qa_la_LIBADD = \
+ libgnuradio-howto.la \
+ $(CPPUNIT_LIBS)
+
+# ----------------------------------------------------------------
+# headers that don't get installed
+# ----------------------------------------------------------------
+noinst_HEADERS = \
+ qa_howto.h \
+ qa_howto_square_ff.h \
+ qa_howto_square2_ff.h
+
+# ----------------------------------------------------------------
+# test program
+# ----------------------------------------------------------------
+noinst_PROGRAMS = \
+ test_all
+
+test_all_SOURCES = test_all.cc
+test_all_LDADD = libgnuradio-howto-qa.la