summaryrefslogtreecommitdiff
path: root/gr-howto-write-a-block/lib/Makefile.am
diff options
context:
space:
mode:
authorJohnathan Corgan2009-11-03 14:24:43 -0800
committerJohnathan Corgan2009-11-03 14:24:43 -0800
commit0bde79ebad973abdcfa23b4d50261fcee39cc28e (patch)
tree1bcc8ed9a899688afe3afdc93e9bcca87a7047b1 /gr-howto-write-a-block/lib/Makefile.am
parent3e366411a75b47eff5f76c76beb1f3a47006f6c7 (diff)
parent26d9beb0b51945915798e75ab24051adaa46d083 (diff)
downloadgnuradio-0bde79ebad973abdcfa23b4d50261fcee39cc28e.tar.gz
gnuradio-0bde79ebad973abdcfa23b4d50261fcee39cc28e.tar.bz2
gnuradio-0bde79ebad973abdcfa23b4d50261fcee39cc28e.zip
Merge branch 'wip/howto' of git@gnuradio.org:jcorgan
* 'wip/howto' of git@gnuradio.org:jcorgan: howto: moved osbsolete docs directory into limbo howto: make swig directory use individual .i files howto: reorganized directory structure howto: implement dynamic versioning howto: update m4 files to match latest master howto: updated INSTALL, fixed mode of config.*
Diffstat (limited to 'gr-howto-write-a-block/lib/Makefile.am')
-rw-r--r--gr-howto-write-a-block/lib/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/gr-howto-write-a-block/lib/Makefile.am b/gr-howto-write-a-block/lib/Makefile.am
new file mode 100644
index 000000000..e553c193d
--- /dev/null
+++ b/gr-howto-write-a-block/lib/Makefile.am
@@ -0,0 +1,42 @@
+#
+# Copyright 2004,2005,2006,2008,2009 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+###################################
+# howto C++ library
+
+# C/C++ headers get installed in ${prefix}/include/gnuradio
+grinclude_HEADERS = \
+ howto_square_ff.h \
+ howto_square2_ff.h
+
+lib_LTLIBRARIES = libgnuradio-howto.la
+
+libgnuradio_howto_la_SOURCES = \
+ howto_square_ff.cc \
+ howto_square2_ff.cc
+
+libgnuradio_howto_la_LIBADD = \
+ $(GNURADIO_CORE_LA)
+
+libgnuradio_howto_la_LDFLAGS = \
+ $(NO_UNDEFINED)