summaryrefslogtreecommitdiff
path: root/gr-howto-write-a-block/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael L Dickens2013-01-01 21:42:23 -0500
committerMichael L Dickens2013-01-01 21:42:23 -0500
commite788c523d4f8de3efd64a64f148ac1bf25ea032d (patch)
treec6c243c3770f65a71cb9f3990dd2dd8c27bdb422 /gr-howto-write-a-block/CMakeLists.txt
parent053d729bcaa6e88791ae21f4c29f3df631aaab65 (diff)
downloadgnuradio-e788c523d4f8de3efd64a64f148ac1bf25ea032d.tar.gz
gnuradio-e788c523d4f8de3efd64a64f148ac1bf25ea032d.tar.bz2
gnuradio-e788c523d4f8de3efd64a64f148ac1bf25ea032d.zip
Tweak INCLUDE dirs such that INCLUDE_DIRECTORIES and LINK_DIRECTORIES are ordered as: internal build and source for this component, other components (internal build and source, or already installed), non-project non-system dependencies (e.g., Qt, Boost, Python), system dependencies (e.g., CoreAudio).
Diffstat (limited to 'gr-howto-write-a-block/CMakeLists.txt')
-rw-r--r--gr-howto-write-a-block/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/gr-howto-write-a-block/CMakeLists.txt b/gr-howto-write-a-block/CMakeLists.txt
index 5d2477f89..02b13c6b6 100644
--- a/gr-howto-write-a-block/CMakeLists.txt
+++ b/gr-howto-write-a-block/CMakeLists.txt
@@ -99,15 +99,15 @@ endif()
########################################################################
include_directories(
${CMAKE_SOURCE_DIR}/include
- ${Boost_INCLUDE_DIRS}
- ${GRUEL_INCLUDE_DIRS}
${GNURADIO_CORE_INCLUDE_DIRS}
+ ${GRUEL_INCLUDE_DIRS}
+ ${Boost_INCLUDE_DIRS}
)
link_directories(
- ${Boost_LIBRARY_DIRS}
- ${GRUEL_LIBRARY_DIRS}
${GNURADIO_CORE_LIBRARY_DIRS}
+ ${GRUEL_LIBRARY_DIRS}
+ ${Boost_LIBRARY_DIRS}
)
# Set component parameters