summaryrefslogtreecommitdiff
path: root/gr-howto-write-a-block-cmake/docs/doxygen/doxyxml/Makefile.am
diff options
context:
space:
mode:
authorTom Rondeau2011-11-27 20:27:35 -0500
committerTom Rondeau2011-11-27 20:27:35 -0500
commitc04d53d32513a48187aa51efc9e99e9a140a2689 (patch)
tree4a4e1e25ae9b2be5d65c9396e654d699ed90c7b8 /gr-howto-write-a-block-cmake/docs/doxygen/doxyxml/Makefile.am
parent355dbf5b35e2c4ebbce6c5d7d1ef5a3b0f5610ce (diff)
downloadgnuradio-c04d53d32513a48187aa51efc9e99e9a140a2689.tar.gz
gnuradio-c04d53d32513a48187aa51efc9e99e9a140a2689.tar.bz2
gnuradio-c04d53d32513a48187aa51efc9e99e9a140a2689.zip
docs: added doxygen and swig docs building tools into howto (cmake version only).
Diffstat (limited to 'gr-howto-write-a-block-cmake/docs/doxygen/doxyxml/Makefile.am')
-rw-r--r--gr-howto-write-a-block-cmake/docs/doxygen/doxyxml/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/gr-howto-write-a-block-cmake/docs/doxygen/doxyxml/Makefile.am b/gr-howto-write-a-block-cmake/docs/doxygen/doxyxml/Makefile.am
new file mode 100644
index 000000000..141f46e5a
--- /dev/null
+++ b/gr-howto-write-a-block-cmake/docs/doxygen/doxyxml/Makefile.am
@@ -0,0 +1,52 @@
+#
+# Copyright 2007,2009,2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+EXTRA_DIST = \
+ example/aadvark.cc \
+ example/aadvark.h \
+ example/Doxyfile \
+ example/xml/aadvark_8cc.xml \
+ example/xml/aadvark_8h.xml \
+ example/xml/classAadvark.xml \
+ example/xml/combine.xslt \
+ example/xml/compound.xsd \
+ example/xml/index.xml \
+ example/xml/index.xsd
+
+if PYTHON
+utilspythondir = $(grpythondir)/doxyxml
+
+TESTS = \
+ run_tests
+
+nobase_utilspython_PYTHON = \
+ __init__.py \
+ base.py \
+ doxyindex.py \
+ text.py \
+ generated/__init__.py \
+ generated/index.py \
+ generated/indexsuper.py \
+ generated/compound.py \
+ generated/compoundsuper.py
+endif \ No newline at end of file