summaryrefslogtreecommitdiff
path: root/gr-howto-write-a-block-cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau2012-02-10 11:10:48 -0500
committerTom Rondeau2012-02-10 11:10:48 -0500
commitdc339fb8c9455ac5089749d7e1d695e0d3642559 (patch)
treeb8c6af84dda8f8c7e45666c5c329c1d3ca05ad90 /gr-howto-write-a-block-cmake/CMakeLists.txt
parentc2c8a53bee19e820859d01d8657821127c75b762 (diff)
parentce7d3555a1a550e29d20af1669a9c9d1e71c8c36 (diff)
downloadgnuradio-dc339fb8c9455ac5089749d7e1d695e0d3642559.tar.gz
gnuradio-dc339fb8c9455ac5089749d7e1d695e0d3642559.tar.bz2
gnuradio-dc339fb8c9455ac5089749d7e1d695e0d3642559.zip
Merge branch 'maint'
Diffstat (limited to 'gr-howto-write-a-block-cmake/CMakeLists.txt')
-rw-r--r--gr-howto-write-a-block-cmake/CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/gr-howto-write-a-block-cmake/CMakeLists.txt b/gr-howto-write-a-block-cmake/CMakeLists.txt
index 9d2d18258..58285ae8f 100644
--- a/gr-howto-write-a-block-cmake/CMakeLists.txt
+++ b/gr-howto-write-a-block-cmake/CMakeLists.txt
@@ -115,6 +115,18 @@ set(GR_HOWTO_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/include CACHE INTERNAL ""
set(GR_HOWTO_SWIG_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/swig CACHE INTERNAL "" FORCE)
########################################################################
+# Create uninstall target
+########################################################################
+configure_file(
+ ${CMAKE_SOURCE_DIR}/cmake/cmake_uninstall.cmake.in
+ ${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake
+@ONLY)
+
+add_custom_target(uninstall
+ ${CMAKE_COMMAND} -P ${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake
+)
+
+########################################################################
# Add subdirectories
########################################################################
add_subdirectory(include)
@@ -123,4 +135,4 @@ add_subdirectory(swig)
add_subdirectory(python)
add_subdirectory(grc)
add_subdirectory(apps)
-add_subdirectory(docs) \ No newline at end of file
+add_subdirectory(docs)