summaryrefslogtreecommitdiff
path: root/gr-gpio/src/fpga/lib/Makefile.am
diff options
context:
space:
mode:
authorEric Blossom2010-11-24 17:29:11 -0800
committerEric Blossom2010-11-24 17:29:11 -0800
commitd692a41f98e7b888c745efbb9fcbbb0400f39025 (patch)
tree591782e695d1d29f2dfcfe6390fc21cd99a06a16 /gr-gpio/src/fpga/lib/Makefile.am
parent42fe3e571be14e70cb06ea1244125553f0606be4 (diff)
downloadgnuradio-d692a41f98e7b888c745efbb9fcbbb0400f39025.tar.gz
gnuradio-d692a41f98e7b888c745efbb9fcbbb0400f39025.tar.bz2
gnuradio-d692a41f98e7b888c745efbb9fcbbb0400f39025.zip
Major Makefile.am housecleaning. Passes distcheck.
Move all occurrences of swig_built_sources out of Makefile.am's. Move all SWIG related use of BUILT_SOURCES out of Makefile.am's. Clean up 'if PYTHON' conditionalization in gr-* Still left to do: fix Makefile.swig CLEANFILES and no_dist_files such that they remove exactly the generated files.
Diffstat (limited to 'gr-gpio/src/fpga/lib/Makefile.am')
-rw-r--r--gr-gpio/src/fpga/lib/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/gr-gpio/src/fpga/lib/Makefile.am b/gr-gpio/src/fpga/lib/Makefile.am
index 2bed79c29..85fec113f 100644
--- a/gr-gpio/src/fpga/lib/Makefile.am
+++ b/gr-gpio/src/fpga/lib/Makefile.am
@@ -19,9 +19,11 @@
# Boston, MA 02110-1301, USA.
#
+include $(top_srcdir)/Makefile.common
+
SUBDIRS =
-EXTRA_DIST = \
+EXTRA_DIST += \
gpio_input.v \
io_pins.v \
rx_chain_dig.v \