summaryrefslogtreecommitdiff
path: root/gr-fcd/swig/CMakeLists.txt
diff options
context:
space:
mode:
authorJohnathan Corgan2012-07-03 14:22:41 -0700
committerJohnathan Corgan2012-07-03 14:22:41 -0700
commit06c325cb925555d1864d67db20490eb67402868d (patch)
tree5f0bf759ce17a61504a4d0f10431406bfcd08bbd /gr-fcd/swig/CMakeLists.txt
parent76258270f53da9a7b6bdeed0b38dde735956012e (diff)
downloadgnuradio-06c325cb925555d1864d67db20490eb67402868d.tar.gz
gnuradio-06c325cb925555d1864d67db20490eb67402868d.tar.bz2
gnuradio-06c325cb925555d1864d67db20490eb67402868d.zip
swig: added GR_SWIG_TARGET_DEPS core_swig to other swig builds
I have not encountered an issue, however this is the correct thing to do. Now individual components swig builds depend on the gr core swig target. Conflicts: gr-filter/swig/CMakeLists.txt
Diffstat (limited to 'gr-fcd/swig/CMakeLists.txt')
-rw-r--r--gr-fcd/swig/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/gr-fcd/swig/CMakeLists.txt b/gr-fcd/swig/CMakeLists.txt
index f715c4785..73676ae6a 100644
--- a/gr-fcd/swig/CMakeLists.txt
+++ b/gr-fcd/swig/CMakeLists.txt
@@ -25,6 +25,8 @@ include(GrSwig)
#set(GR_SWIG_FLAGS -DGR_HAVE_FCD) #needed to parse fcd_swig.i
+set(GR_SWIG_TARGET_DEPS core_swig)
+
set(GR_SWIG_INCLUDE_DIRS
${GR_FCD_INCLUDE_DIRS}
${GNURADIO_CORE_SWIG_INCLUDE_DIRS}