summaryrefslogtreecommitdiff
path: root/gr-fcd/lib/hid/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Dickens2012-03-13 09:14:52 -0700
committerJohnathan Corgan2012-03-13 09:14:52 -0700
commit85beb37cac923798fa0ea6f27a3413e174e43367 (patch)
tree4bfb38d6d618bb990222118200fb9735d230c174 /gr-fcd/lib/hid/CMakeLists.txt
parent704afafe874735a8b260870efb1ed11c2c85eff4 (diff)
downloadgnuradio-85beb37cac923798fa0ea6f27a3413e174e43367.tar.gz
gnuradio-85beb37cac923798fa0ea6f27a3413e174e43367.tar.bz2
gnuradio-85beb37cac923798fa0ea6f27a3413e174e43367.zip
fcd: implement conditional build for MacOSX
Diffstat (limited to 'gr-fcd/lib/hid/CMakeLists.txt')
-rw-r--r--gr-fcd/lib/hid/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/gr-fcd/lib/hid/CMakeLists.txt b/gr-fcd/lib/hid/CMakeLists.txt
index d18e977c2..db335cc93 100644
--- a/gr-fcd/lib/hid/CMakeLists.txt
+++ b/gr-fcd/lib/hid/CMakeLists.txt
@@ -27,7 +27,7 @@ set(hid_sources)
if(WIN32)
list(APPEND hid_sources ${CMAKE_CURRENT_SOURCE_DIR}/hidwin.c)
-elseif(MACOSX)
+elseif(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
list(APPEND hid_sources ${CMAKE_CURRENT_SOURCE_DIR}/hidmac.c)
else()
list(APPEND hid_sources ${CMAKE_CURRENT_SOURCE_DIR}/hid-libusb.c)