summaryrefslogtreecommitdiff
path: root/gr-fcd/lib/fcd/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau2012-03-27 21:46:48 -0400
committerTom Rondeau2012-03-27 21:46:48 -0400
commit8bfb47dd8fb661039bdfdc475047e6f983f11270 (patch)
tree448402699fabea713d3f54b35e7733617d273ab3 /gr-fcd/lib/fcd/CMakeLists.txt
parentda09d2b000606b55f564bc6adaa945968d6c3e72 (diff)
parent79e341d9064b8e44c2d1900cb34ddb51deebb559 (diff)
downloadgnuradio-8bfb47dd8fb661039bdfdc475047e6f983f11270.tar.gz
gnuradio-8bfb47dd8fb661039bdfdc475047e6f983f11270.tar.bz2
gnuradio-8bfb47dd8fb661039bdfdc475047e6f983f11270.zip
Merge branch 'master' of gnuradio.org:gnuradio
Diffstat (limited to 'gr-fcd/lib/fcd/CMakeLists.txt')
-rw-r--r--gr-fcd/lib/fcd/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/gr-fcd/lib/fcd/CMakeLists.txt b/gr-fcd/lib/fcd/CMakeLists.txt
new file mode 100644
index 000000000..416a7507e
--- /dev/null
+++ b/gr-fcd/lib/fcd/CMakeLists.txt
@@ -0,0 +1,32 @@
+# Copyright 2012 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+
+include_directories(APPEND ${USB_INCLUDES})
+
+set(fcd_sources ${CMAKE_CURRENT_SOURCE_DIR}/fcd.c)
+
+
+########################################################################
+# Append gnuradio-fcd library sources
+########################################################################
+list(APPEND gr_fcd_sources ${fcd_sources})