summaryrefslogtreecommitdiff
path: root/gr-fcd/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael L Dickens2013-01-01 21:42:23 -0500
committerMichael L Dickens2013-01-01 21:42:23 -0500
commite788c523d4f8de3efd64a64f148ac1bf25ea032d (patch)
treec6c243c3770f65a71cb9f3990dd2dd8c27bdb422 /gr-fcd/lib/CMakeLists.txt
parent053d729bcaa6e88791ae21f4c29f3df631aaab65 (diff)
downloadgnuradio-e788c523d4f8de3efd64a64f148ac1bf25ea032d.tar.gz
gnuradio-e788c523d4f8de3efd64a64f148ac1bf25ea032d.tar.bz2
gnuradio-e788c523d4f8de3efd64a64f148ac1bf25ea032d.zip
Tweak INCLUDE dirs such that INCLUDE_DIRECTORIES and LINK_DIRECTORIES are ordered as: internal build and source for this component, other components (internal build and source, or already installed), non-project non-system dependencies (e.g., Qt, Boost, Python), system dependencies (e.g., CoreAudio).
Diffstat (limited to 'gr-fcd/lib/CMakeLists.txt')
-rw-r--r--gr-fcd/lib/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/gr-fcd/lib/CMakeLists.txt b/gr-fcd/lib/CMakeLists.txt
index 9a5605d99..a5c95ceb7 100644
--- a/gr-fcd/lib/CMakeLists.txt
+++ b/gr-fcd/lib/CMakeLists.txt
@@ -24,15 +24,16 @@ GR_INCLUDE_SUBDIRECTORY(fcd)
# Setup the include and linker paths
########################################################################
include_directories(
- ${GNURADIO_CORE_INCLUDE_DIRS}
- ${GR_FCD_INCLUDE_DIRS}
- ${GR_AUDIO_INCLUDE_DIRS}
${CMAKE_CURRENT_SOURCE_DIR}/hid
${CMAKE_CURRENT_SOURCE_DIR}/fcd
+ ${GR_FCD_INCLUDE_DIRS}
+ ${GR_AUDIO_INCLUDE_DIRS}
+ ${GNURADIO_CORE_INCLUDE_DIRS}
+ ${GRUEL_INCLUDE_DIRS}
+ ${Boost_INCLUDE_DIRS}
${LIBUSB_INCLUDE_DIR}
)
-include_directories(${Boost_INCLUDE_DIRS})
link_directories(${Boost_LIBRARY_DIRS})
########################################################################