summaryrefslogtreecommitdiff
path: root/gr-fcd/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJohnathan Corgan2012-03-11 15:18:15 -0700
committerJohnathan Corgan2012-03-11 19:37:40 -0700
commit72576bd2d87b83ccc1661b695278e0dee8fe21a4 (patch)
tree045f8e269cd98b9574be9ccceff6eaea61ad4b10 /gr-fcd/lib/CMakeLists.txt
parent9f9b2f0b7527b1a82dfad5337c33fac5aef30ca4 (diff)
downloadgnuradio-72576bd2d87b83ccc1661b695278e0dee8fe21a4.tar.gz
gnuradio-72576bd2d87b83ccc1661b695278e0dee8fe21a4.tar.bz2
gnuradio-72576bd2d87b83ccc1661b695278e0dee8fe21a4.zip
fcd: cmake build work in progress
Diffstat (limited to 'gr-fcd/lib/CMakeLists.txt')
-rw-r--r--gr-fcd/lib/CMakeLists.txt60
1 files changed, 60 insertions, 0 deletions
diff --git a/gr-fcd/lib/CMakeLists.txt b/gr-fcd/lib/CMakeLists.txt
new file mode 100644
index 000000000..b41037d4a
--- /dev/null
+++ b/gr-fcd/lib/CMakeLists.txt
@@ -0,0 +1,60 @@
+# Copyright 2012 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+GR_INCLUDE_SUBDIRECTORY(hid)
+GR_INCLUDE_SUBDIRECTORY(fcd)
+
+########################################################################
+# Setup the include and linker paths
+########################################################################
+include_directories(
+ ${GNURADIO_CORE_INCLUDE_DIRS}
+ ${GR_FCD_INCLUDE_DIRS}
+ ${GR_AUDIO_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_SOURCE_DIR}/hid
+ ${CMAKE_CURRENT_SOURCE_DIR}/fcd
+ ${LIBUSB_INCLUDE_DIR}
+)
+
+include_directories(${Boost_INCLUDE_DIRS})
+link_directories(${Boost_LIBRARY_DIRS})
+
+########################################################################
+# Setup library
+########################################################################
+list(APPEND gr_fcd_sources
+ fcd_source_c.cc
+)
+
+list(APPEND fcd_libs
+ gnuradio-core
+ gnuradio-audio
+ ${Boost_LIBRARIES}
+)
+
+if(NOT WIN32 AND NOT MACOSX)
+ list(APPEND fcd_libs
+ ${LIBUSB_LIBRARIES}
+ )
+endif()
+
+
+add_library(gnuradio-fcd SHARED ${gr_fcd_sources})
+target_link_libraries(gnuradio-fcd ${fcd_libs})
+GR_LIBRARY_FOO(gnuradio-fcd RUNTIME_COMPONENT "fcd_runtime" DEVEL_COMPONENT "fcd_devel")