summaryrefslogtreecommitdiff
path: root/gr-digital/swig/Makefile.am
diff options
context:
space:
mode:
authorTom Rondeau2011-11-27 14:56:19 -0500
committerTom Rondeau2011-11-27 14:56:19 -0500
commit0a21e2584c226496af2aa3b361bed3d6bd91ba41 (patch)
tree444074fc00018a88f1e9c5938f3c0b63c1e0d8c2 /gr-digital/swig/Makefile.am
parent7b57dae20bb182561fcda78e5eeec44e44f0a9fb (diff)
downloadgnuradio-0a21e2584c226496af2aa3b361bed3d6bd91ba41.tar.gz
gnuradio-0a21e2584c226496af2aa3b361bed3d6bd91ba41.tar.bz2
gnuradio-0a21e2584c226496af2aa3b361bed3d6bd91ba41.zip
docs: autotools Makefile.am generates empty swig_docs .i files; builds in autotools and cmake.
The autotools build does not auto-generate the Python documentation for each block like we do with the cmake build, but the empty .i files are required to build things regardless. The swig_doc.py and doxyxml files are distributed with the autotools build in case someone wants to generate this on their own (see README.doxyxml for how to do this). Only for gnuradio-core and gr-digital currently.
Diffstat (limited to 'gr-digital/swig/Makefile.am')
-rw-r--r--gr-digital/swig/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/gr-digital/swig/Makefile.am b/gr-digital/swig/Makefile.am
index 1afa44743..e7967b09b 100644
--- a/gr-digital/swig/Makefile.am
+++ b/gr-digital/swig/Makefile.am
@@ -31,6 +31,15 @@ AM_CPPFLAGS = \
$(PYTHON_CPPFLAGS) \
$(WITH_INCLUDES)
+TOP_SWIG_DOC_IFILES = \
+ digital_swig_doc.i
+
+BUILT_SOURCES = \
+ $(TOP_SWIG_DOC_IFILES)
+
+$(BUILT_SOURCES):
+ `echo "" > $@`
+
if GUILE
nobase_guile_DATA = \
gnuradio/digital.scm