summaryrefslogtreecommitdiff
path: root/gr-digital/swig/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau2011-12-23 13:28:06 -0500
committerTom Rondeau2011-12-23 13:28:06 -0500
commit6a78e0a8ae6dc17a12ab5e397f1452a1a363e7d1 (patch)
tree28e3d86e87a758c1024f30c67b1675a9300cc3cb /gr-digital/swig/CMakeLists.txt
parentc1c68974a6677f6dd81b1fb6e3c129e8d08c1fd0 (diff)
downloadgnuradio-6a78e0a8ae6dc17a12ab5e397f1452a1a363e7d1.tar.gz
gnuradio-6a78e0a8ae6dc17a12ab5e397f1452a1a363e7d1.tar.bz2
gnuradio-6a78e0a8ae6dc17a12ab5e397f1452a1a363e7d1.zip
digital: added a class, digital_mpsk_snr_est_cc, that estimates the SNR of an M-ary PSK signal.
This block can calculate the SNR using 1 of 4 different methods specified in the block's constructor. They (tend to) trade off accuracy for computational performnace.
Diffstat (limited to 'gr-digital/swig/CMakeLists.txt')
-rw-r--r--gr-digital/swig/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/gr-digital/swig/CMakeLists.txt b/gr-digital/swig/CMakeLists.txt
index dd6097286..136f9e43f 100644
--- a/gr-digital/swig/CMakeLists.txt
+++ b/gr-digital/swig/CMakeLists.txt
@@ -59,6 +59,7 @@ install(
digital_lms_dd_equalizer_cc.i
digital_kurtotic_equalizer_cc.i
digital_mpsk_receiver_cc.i
+ digital_mpsk_snr_est_cc.i
digital_ofdm_cyclic_prefixer.i
digital_ofdm_frame_acquisition.i
digital_ofdm_frame_sink.i