summaryrefslogtreecommitdiff
path: root/gr-digital/python/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum2011-07-20 20:57:28 -0700
committerJosh Blum2011-07-20 20:57:28 -0700
commit404840194223637c34a71fd45c1bc8438889f57d (patch)
tree413b7eababc3915142e15d91f9a2fd9f430bc557 /gr-digital/python/CMakeLists.txt
parentaccb9f2fe8fd8f6a1e114adac5b15304b0e0012d (diff)
downloadgnuradio-404840194223637c34a71fd45c1bc8438889f57d.tar.gz
gnuradio-404840194223637c34a71fd45c1bc8438889f57d.tar.bz2
gnuradio-404840194223637c34a71fd45c1bc8438889f57d.zip
digital: added cmake support for gr-digital (unix only)
Diffstat (limited to 'gr-digital/python/CMakeLists.txt')
-rw-r--r--gr-digital/python/CMakeLists.txt71
1 files changed, 71 insertions, 0 deletions
diff --git a/gr-digital/python/CMakeLists.txt b/gr-digital/python/CMakeLists.txt
new file mode 100644
index 000000000..9fb110a61
--- /dev/null
+++ b/gr-digital/python/CMakeLists.txt
@@ -0,0 +1,71 @@
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# Setup python install
+########################################################################
+INCLUDE(GrPython)
+
+GR_PYTHON_INSTALL(
+ FILES
+ __init__.py
+ psk.py
+ dbpsk.py
+ dqpsk.py
+ d8psk.py
+ psk2.py
+ generic_mod_demod.py
+ qam.py
+ bpsk.py
+ qpsk.py
+ ofdm.py
+ pkt.py
+ modulation_utils2.py
+ DESTINATION ${GR_PYTHON_DIR}/gnuradio/digital
+ COMPONENT "digital_python"
+)
+
+GR_PYTHON_INSTALL(
+ FILES
+ utils/__init__.py
+ utils/gray_code.py
+ utils/mod_codes.py
+ utils/alignment.py
+ DESTINATION ${GR_PYTHON_DIR}/gnuradio/digital/utils
+ COMPONENT "digital_python"
+)
+
+########################################################################
+# Handle the unit tests
+########################################################################
+IF(ENABLE_TESTING)
+INCLUDE(GrTest)
+FILE(GLOB py_qa_test_files "qa_*.py")
+FOREACH(py_qa_test_file ${py_qa_test_files})
+ GET_FILENAME_COMPONENT(py_qa_test_name ${py_qa_test_file} NAME_WE)
+ SET(GR_TEST_PYTHON_DIRS
+ ${CMAKE_BINARY_DIR}/gnuradio-core/src/python
+ ${CMAKE_BINARY_DIR}/gnuradio-core/src/lib/swig
+ ${CMAKE_BINARY_DIR}/gr-digital/python
+ ${CMAKE_BINARY_DIR}/gr-digital/swig
+ )
+ SET(GR_TEST_TARGET_DEPS gruel gnuradio-core gnuradio-qtgui)
+ GR_ADD_TEST(${py_qa_test_name} ${PYTHON_EXECUTABLE} ${py_qa_test_file})
+ENDFOREACH(py_qa_test_file)
+ENDIF(ENABLE_TESTING)