summaryrefslogtreecommitdiff
path: root/gr-cvsd-vocoder/src/lib/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2009-03-14 02:28:41 +0000
committerjcorgan2009-03-14 02:28:41 +0000
commitc3f962a1f0a4132ad643c58774bb69b190dccc49 (patch)
treedaa59a206d6fde01dc1404197e981927366af0e0 /gr-cvsd-vocoder/src/lib/Makefile.am
parent4eea337c46db44a6ee7560a4552e158421776777 (diff)
downloadgnuradio-c3f962a1f0a4132ad643c58774bb69b190dccc49.tar.gz
gnuradio-c3f962a1f0a4132ad643c58774bb69b190dccc49.tar.bz2
gnuradio-c3f962a1f0a4132ad643c58774bb69b190dccc49.zip
Merged r10554:10595 from michaelld/am_swig_4 into trunk. Major overhaul of SWIG usage in build system, also fixes ticket:130. Trunk passes distcheck.
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@10596 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gr-cvsd-vocoder/src/lib/Makefile.am')
-rw-r--r--gr-cvsd-vocoder/src/lib/Makefile.am86
1 files changed, 25 insertions, 61 deletions
diff --git a/gr-cvsd-vocoder/src/lib/Makefile.am b/gr-cvsd-vocoder/src/lib/Makefile.am
index 2306bc3b8..78a7c6400 100644
--- a/gr-cvsd-vocoder/src/lib/Makefile.am
+++ b/gr-cvsd-vocoder/src/lib/Makefile.am
@@ -21,75 +21,39 @@
include $(top_srcdir)/Makefile.common
-# Install this stuff so that it ends up as the gnuradio.vocoder module
-# This usually ends up at:
-# ${prefix}/lib/python${python_version}/site-packages/gnuradio/vocoder
-
-ourpythondir = $(grpythondir)/vocoder
-ourlibdir = $(grpyexecdir)/vocoder
-
AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
-ALL_IFILES = \
- $(LOCAL_IFILES) \
- $(NON_LOCAL_IFILES)
-
-NON_LOCAL_IFILES = \
- $(GNURADIO_I)
-
-LOCAL_IFILES = \
- $(srcdir)/cvsd_vocoder.i
-
-# These files are built by SWIG. The first is the C++ glue.
-# The second is the python wrapper that loads the _howto shared library
-# and knows how to call our extensions.
+# These headers get installed in ${prefix}/include/gnuradio
+grinclude_HEADERS = \
+ cvsd_decode_bs.h \
+ cvsd_encode_sb.h
-BUILT_SOURCES = \
- cvsd_vocoder.cc \
- cvsd_vocoder.py
+###################################
+# SWIG Python interface and library
-# This gets cvsd_vocoder.py installed in the right place
-ourpython_PYTHON = \
- cvsd_vocoder.py
+TOP_SWIG_IFILES = \
+ cvsd_vocoder.i
-ourlib_LTLIBRARIES = _cvsd_vocoder.la
+# Install so that they end up available as:
+# import gnuradio.vocoder.cvsd_vocoder
+# This ends up at:
+# ${prefix}/lib/python${python_version}/site-packages/gnuradio/vocoder
+cvsd_vocoder_pythondir_category = \
+ gnuradio/vocoder
-# These are the source files that go into the shared library
-_cvsd_vocoder_la_SOURCES = \
+# additional sources for the SWIG-generated library
+cvsd_vocoder_la_swig_sources = \
cvsd_decode_bs.cc \
- cvsd_encode_sb.cc \
- cvsd_vocoder.cc
-
-
-# magic flags
-_cvsd_vocoder_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
-
-# link the library against the c++ standard library
-_cvsd_vocoder_la_LIBADD = \
- $(PYTHON_LDFLAGS) \
- $(GNURADIO_CORE_LA) \
- -lstdc++
-
-_cvsd_vocoder_la_CXXFLAGS = @swig_CXXFLAGS@
-
-cvsd_vocoder.cc cvsd_vocoder.py: $(ALL_IFILES)
- $(SWIG) $(STD_SWIG_PYTHON_ARGS) -module cvsd_vocoder \
- -o cvsd_vocoder.cc $(LOCAL_IFILES)
-
-# These headers get installed in ${prefix}/include/gnuradio
-grinclude_HEADERS = \
- cvsd_decode_bs.h \
- cvsd_encode_sb.h
-
-# These swig headers get installed in ${prefix}/include/gnuradio/swig
-swiginclude_HEADERS = \
- $(LOCAL_IFILES)
+ cvsd_encode_sb.cc
+# additional libraries for linking with the SWIG-generated library
+cvsd_vocoder_la_swig_libadd = \
+ $(GNURADIO_CORE_LA)
-MOSTLYCLEANFILES = $(BUILT_SOURCES) *.pyc
+include $(top_srcdir)/Makefile.swig
-# Don't distribute output of swig
-dist-hook:
- @for file in $(BUILT_SOURCES); do echo $(RM) $(distdir)/$$file; done
- @for file in $(BUILT_SOURCES); do $(RM) $(distdir)/$$file; done
+# add some of the variables generated inside the Makefile.swig.gen
+BUILT_SOURCES = $(swig_built_sources)
+# Do not distribute the output of SWIG
+no_dist_files = $(swig_built_sources)