summaryrefslogtreecommitdiff
path: root/gr-comedi/src/Makefile.am
diff options
context:
space:
mode:
authorEric Blossom2010-11-24 17:29:11 -0800
committerEric Blossom2010-11-24 17:29:11 -0800
commitd692a41f98e7b888c745efbb9fcbbb0400f39025 (patch)
tree591782e695d1d29f2dfcfe6390fc21cd99a06a16 /gr-comedi/src/Makefile.am
parent42fe3e571be14e70cb06ea1244125553f0606be4 (diff)
downloadgnuradio-d692a41f98e7b888c745efbb9fcbbb0400f39025.tar.gz
gnuradio-d692a41f98e7b888c745efbb9fcbbb0400f39025.tar.bz2
gnuradio-d692a41f98e7b888c745efbb9fcbbb0400f39025.zip
Major Makefile.am housecleaning. Passes distcheck.
Move all occurrences of swig_built_sources out of Makefile.am's. Move all SWIG related use of BUILT_SOURCES out of Makefile.am's. Clean up 'if PYTHON' conditionalization in gr-* Still left to do: fix Makefile.swig CLEANFILES and no_dist_files such that they remove exactly the generated files.
Diffstat (limited to 'gr-comedi/src/Makefile.am')
-rw-r--r--gr-comedi/src/Makefile.am21
1 files changed, 8 insertions, 13 deletions
diff --git a/gr-comedi/src/Makefile.am b/gr-comedi/src/Makefile.am
index dd759d8a0..47f689adb 100644
--- a/gr-comedi/src/Makefile.am
+++ b/gr-comedi/src/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2005,2008,2009 Free Software Foundation, Inc.
+# Copyright 2005,2008,2009,2010 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -20,9 +20,12 @@
#
include $(top_srcdir)/Makefile.common
+include $(top_srcdir)/Makefile.swig
TESTS =
-EXTRA_DIST = run_tests.in
+EXTRA_DIST += run_tests.in
+DISTCLEANFILES += run_tests
+
AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
@@ -50,11 +53,8 @@ libgnuradio_comedi_la_LIBADD = \
libgnuradio_comedi_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
-if PYTHON
###################################
-# SWIG Python interface and library
-TESTS += run_tests
-DISTCLEANFILES = run_tests
+# SWIG interfaces and libraries
TOP_SWIG_IFILES = \
comedi.i
@@ -70,11 +70,6 @@ comedi_pythondir_category = \
comedi_la_swig_libadd = \
libgnuradio-comedi.la
-include $(top_srcdir)/Makefile.swig
-
-# add some of the variables generated inside the Makefile.swig.gen
-BUILT_SOURCES = $(swig_built_sources)
-
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
+if PYTHON
+TESTS += run_tests
endif