summaryrefslogtreecommitdiff
path: root/gr-audio/examples/python/Makefile.am
diff options
context:
space:
mode:
authorJohnathan Corgan2011-07-04 21:00:18 -0700
committerJohnathan Corgan2011-07-04 21:00:18 -0700
commitb7d8980a6e9e070609b4270ad51d8a91ebfb60b2 (patch)
tree81778d3b89ee8fe736d79949b9c8c21701f88975 /gr-audio/examples/python/Makefile.am
parent2930812784e1b2d9325efccc163448e14118af7c (diff)
downloadgnuradio-b7d8980a6e9e070609b4270ad51d8a91ebfb60b2.tar.gz
gnuradio-b7d8980a6e9e070609b4270ad51d8a91ebfb60b2.tar.bz2
gnuradio-b7d8980a6e9e070609b4270ad51d8a91ebfb60b2.zip
gnuradio-examples, gr-audio: moved audio Python and C++ examples into gr-audio
This begins a transition of examples from a separate gnuradio-examples component into an examples directory with the component they go with. In this commit: gnuradio-examples/c++/audio/ => gr-audio/examples/c++ gnuradio-examples/python/audio => gr-audio/examples/python The system installation directory remains $PREFIX/share/gnuradio/examples/audio
Diffstat (limited to 'gr-audio/examples/python/Makefile.am')
-rw-r--r--gr-audio/examples/python/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/gr-audio/examples/python/Makefile.am b/gr-audio/examples/python/Makefile.am
new file mode 100644
index 000000000..356b51559
--- /dev/null
+++ b/gr-audio/examples/python/Makefile.am
@@ -0,0 +1,38 @@
+#
+# Copyright 2004,2009 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+ourdatadir = $(exampledir)/audio
+
+dist_ourdata_SCRIPTS = \
+ audio_copy.py \
+ audio_fft.py \
+ audio_play.py \
+ audio_to_file.py \
+ dial_tone.py \
+ dial_tone_daemon.py \
+ dial_tone_wav.py \
+ mono_tone.py \
+ multi_tone.py \
+ noise.py \
+ spectrum_inversion.py \
+ test_resampler.py