summaryrefslogtreecommitdiff
path: root/gr-audio-windows/src/Makefile.am
diff options
context:
space:
mode:
authorEric Blossom2010-11-24 17:29:11 -0800
committerEric Blossom2010-11-24 17:29:11 -0800
commitd692a41f98e7b888c745efbb9fcbbb0400f39025 (patch)
tree591782e695d1d29f2dfcfe6390fc21cd99a06a16 /gr-audio-windows/src/Makefile.am
parent42fe3e571be14e70cb06ea1244125553f0606be4 (diff)
downloadgnuradio-d692a41f98e7b888c745efbb9fcbbb0400f39025.tar.gz
gnuradio-d692a41f98e7b888c745efbb9fcbbb0400f39025.tar.bz2
gnuradio-d692a41f98e7b888c745efbb9fcbbb0400f39025.zip
Major Makefile.am housecleaning. Passes distcheck.
Move all occurrences of swig_built_sources out of Makefile.am's. Move all SWIG related use of BUILT_SOURCES out of Makefile.am's. Clean up 'if PYTHON' conditionalization in gr-* Still left to do: fix Makefile.swig CLEANFILES and no_dist_files such that they remove exactly the generated files.
Diffstat (limited to 'gr-audio-windows/src/Makefile.am')
-rw-r--r--gr-audio-windows/src/Makefile.am19
1 files changed, 6 insertions, 13 deletions
diff --git a/gr-audio-windows/src/Makefile.am b/gr-audio-windows/src/Makefile.am
index 97dc49f5a..1d7b253ec 100644
--- a/gr-audio-windows/src/Makefile.am
+++ b/gr-audio-windows/src/Makefile.am
@@ -20,10 +20,11 @@
#
include $(top_srcdir)/Makefile.common
+include $(top_srcdir)/Makefile.swig
TESTS =
-
-EXTRA_DIST = run_tests.in
+DISTCLEANFILES += run_tests
+EXTRA_DIST += run_tests.in
AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
@@ -49,11 +50,8 @@ libgnuradio_audio_windows_la_LDFLAGS = \
$(NO_UNDEFINED) \
$(LTVERSIONFLAGS)
-if PYTHON
###################################
-# SWIG Python interface and library
-TESTS += run_tests
-DISTCLEANFILES = run_tests
+# SWIG interface and library
TOP_SWIG_IFILES = \
audio_windows.i
@@ -69,11 +67,6 @@ audio_windows_pythondir_category = \
audio_windows_la_swig_libadd = \
libgnuradio-audio-windows.la
-include $(top_srcdir)/Makefile.swig
-
-# add some of the variables generated inside the Makefile.swig.gen
-BUILT_SOURCES = $(swig_built_sources)
-
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
+if PYTHON
+TESTS += run_tests
endif