summaryrefslogtreecommitdiff
path: root/gr-audio-alsa/src/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2006-08-07 15:41:19 +0000
committerjcorgan2006-08-07 15:41:19 +0000
commite27ba9aebfddf88cd245636d2f652a4ee4e289ec (patch)
tree01f44251578419823c34f140ee58d8fc6016a1c2 /gr-audio-alsa/src/Makefile.am
parent37bee553f670da9c82b5a438fe06df3a1ca8b2aa (diff)
downloadgnuradio-e27ba9aebfddf88cd245636d2f652a4ee4e289ec.tar.gz
gnuradio-e27ba9aebfddf88cd245636d2f652a4ee4e289ec.tar.bz2
gnuradio-e27ba9aebfddf88cd245636d2f652a4ee4e289ec.zip
Fixes for ticket:10, ticket:18, and ticket:19. Merged r3194:3215 from
/gnuradio/branches/developers/jcorgan/ticket-10. 'make distcheck' now successfully completes on a machine that has never had gnuradio installed before. In addition, several cleanups and refactoring of build system code have been applied. NOTE: gr-audio-portaudio, gr-audio-osx, and gr-audio-windows have not been fully tested and will need verification by the maintainers of these components. git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@3216 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gr-audio-alsa/src/Makefile.am')
-rw-r--r--gr-audio-alsa/src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/gr-audio-alsa/src/Makefile.am b/gr-audio-alsa/src/Makefile.am
index e06fef9ae..b6a8ef388 100644
--- a/gr-audio-alsa/src/Makefile.am
+++ b/gr-audio-alsa/src/Makefile.am
@@ -28,8 +28,6 @@ include $(top_srcdir)/Makefile.common
ourpythondir = $(grpythondir)
ourlibdir = $(grpyexecdir)
-LIBS += $(GNURADIO_CORE_LIBS)
-
EXTRA_DIST = run_tests.in
TESTS = run_tests
@@ -38,7 +36,7 @@ LOCAL_IFILES = \
audio_alsa.i
NON_LOCAL_IFILES = \
- $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
+ $(GNURADIO_I)
ALL_IFILES = \
$(LOCAL_IFILES) \
@@ -76,6 +74,8 @@ swiginclude_HEADERS = \
_audio_alsa_la_LIBADD = \
$(PYTHON_LDFLAGS) \
+ $(GNURADIO_CORE_LIBS) \
+ $(ALSA_LIBS) \
-lstdc++
_audio_alsa_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version