summaryrefslogtreecommitdiff
path: root/gr-atsc/src/python/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2007-09-04 02:43:56 +0000
committerjcorgan2007-09-04 02:43:56 +0000
commit54d6b9281dc233e0b2acf26884073d973b7663de (patch)
tree15cd1fa40207e68c5035a50fd7d54536831c4599 /gr-atsc/src/python/Makefile.am
parent2c37e57fe4626ac30eb8c042e4d7daf64a0d45f5 (diff)
downloadgnuradio-54d6b9281dc233e0b2acf26884073d973b7663de.tar.gz
gnuradio-54d6b9281dc233e0b2acf26884073d973b7663de.tar.bz2
gnuradio-54d6b9281dc233e0b2acf26884073d973b7663de.zip
Merged r6271:6278 from jcorgan/t182 into trunk. Implements ticket:182.
Created new top-level component, gr-utils, to hold commonly used utility scripts (originally in gnuradio-examples). These now install into the system path, allowing their use from wherever. Reorganization of gnuradio-examples component: * Commonly used utility scripts moved from python/usrp into gr-utils. * Examples now install into $(prefix)/share/gnuradio/examples/... * Channel coding examples moved into gr-trellis/src/examples, now install from there, only if gr-atsc itself is going to built and installed. * ATSC example scripts now install into example hierarchy * Cruft has been moved into 'limbo' in repository, do not get installed Trunk passes 'make distcheck'. git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@6279 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gr-atsc/src/python/Makefile.am')
-rw-r--r--gr-atsc/src/python/Makefile.am24
1 files changed, 23 insertions, 1 deletions
diff --git a/gr-atsc/src/python/Makefile.am b/gr-atsc/src/python/Makefile.am
index 952bfddb5..ffc7780df 100644
--- a/gr-atsc/src/python/Makefile.am
+++ b/gr-atsc/src/python/Makefile.am
@@ -21,7 +21,20 @@
include $(top_srcdir)/Makefile.common
-EXTRA_DIST = run_tests.in
+EXAMPLE_FILES = \
+ README \
+ btl-fsd.py \
+ fpll.py \
+ interp.py \
+ xlate.py \
+ viterbi-out.py
+
+
+EXTRA_DIST = run_tests.in \
+ $(EXAMPLE_FILES)
+
+ourdatadir = $(exampledir)/atsc
+ourdata_DATA = $(EXAMPLE_FILES)
TESTS = \
@@ -31,3 +44,12 @@ TESTS = \
noinst_PYTHON = \
atsc_utils.py \
qa_atsc.py
+
+# Make example scripts with #! executable
+install-data-local:
+ for i in `find $(ourdatadir) -type f ! -perm 755`; do \
+ if head -1 $$i | grep -q '^#!'; then \
+ chmod 755 $$i; \
+ echo "made executable: $$i"; \
+ fi; \
+ done