summaryrefslogtreecommitdiff
path: root/gr-atsc/src/lib/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2009-05-27 01:54:41 +0000
committerjcorgan2009-05-27 01:54:41 +0000
commit40b8a57d69b4b85f207fb0408347c210e23202cc (patch)
tree8d1e3bbc9159bdd0de98bb897432abd81563dbca /gr-atsc/src/lib/Makefile.am
parente3cd8f7d59aad0ffd51c417b2623ab02588fdb08 (diff)
downloadgnuradio-40b8a57d69b4b85f207fb0408347c210e23202cc.tar.gz
gnuradio-40b8a57d69b4b85f207fb0408347c210e23202cc.tar.bz2
gnuradio-40b8a57d69b4b85f207fb0408347c210e23202cc.zip
Merged r11123:11148 from jcorgan/np into trunk.
Adds --enable-python option to configure (defaults to yes). Using --disable-python or --enable-python=no will cause only C++ API targets to be created and installed. Several new shared libraries are now created. Where in the past, the C++ objects of the actual gnuradio blocks that were in a component were hidden inside their corresponding Python extension modules, these are now split out into a libgnuradio-foo.so library, and the _foo.so Python module is linked to that. This has been the way several top- level components have operated for some time, such as gr-audio-alsa and gr-usrp and gr-usrp2. This changeset applies that pattern to all components. C++ API users can use pkg-config to discover the cflags and libs parameters needed to include and link against these libraries. These components have not been tested: gr-comedi gr-audio-osx gr-audio-windows Passes distcheck. git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@11150 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gr-atsc/src/lib/Makefile.am')
-rw-r--r--gr-atsc/src/lib/Makefile.am32
1 files changed, 18 insertions, 14 deletions
diff --git a/gr-atsc/src/lib/Makefile.am b/gr-atsc/src/lib/Makefile.am
index 905eaa57e..b43546125 100644
--- a/gr-atsc/src/lib/Makefile.am
+++ b/gr-atsc/src/lib/Makefile.am
@@ -32,12 +32,10 @@ EXTRA_DIST = \
qa_atsci_viterbi_decoder_t1_input.dat \
qa_atsci_viterbi_decoder_t1_output.dat
-TESTS = \
- test_atsci
-# We build two libtool convenience libraries
+TESTS = test_atsci
-noinst_LTLIBRARIES = libatsc.la libatsc-qa.la
+lib_LTLIBRARIES = libgnuradio-atsc.la
# FIXME
# atsci_exp2_lp.cc \
@@ -46,7 +44,7 @@ noinst_LTLIBRARIES = libatsc.la libatsc-qa.la
# atsci_vsbtx_lp.cc \
#
-libatsc_la_SOURCES = \
+libgnuradio_atsc_la_SOURCES = \
atsc_derandomizer.cc \
atsc_randomizer.cc \
atsc_rs_decoder.cc \
@@ -88,10 +86,15 @@ libatsc_la_SOURCES = \
create_atsci_fs_correlator.cc \
plinfo.cc
-libatsc_la_LIBADD = \
+BUILT_SOURCES = \
+ atsci_viterbi_mux.cc
+
+libgnuradio_atsc_la_LIBADD = \
$(GNURADIO_CORE_LA)
-libatsc_qa_la_SOURCES = \
+noinst_LTLIBRARIES = libgnuradio-atsc-qa.la
+
+libgnuradio_atsc_qa_la_SOURCES = \
qa_atsci_basic_trellis_encoder.cc \
qa_atsci_data_interleaver.cc \
qa_atsci_equalizer_nop.cc \
@@ -107,9 +110,10 @@ libatsc_qa_la_SOURCES = \
qa_atsci.cc \
qa_interleaver_fifo.cc
-libatsc_qa_la_LIBADD = \
+libgnuradio_atsc_qa_la_LIBADD = \
$(GNURADIO_CORE_LA)
+
# These headers get installed in ${prefix}/include/gnuradio
grinclude_HEADERS = \
atsc_consts.h \
@@ -193,8 +197,8 @@ atsci_viterbi_mux.cc: atsci_viterbi_gen$(EXEEXT)
test_atsci_SOURCES = test_atsci.cc
test_atsci_LDADD = \
- libatsc-qa.la \
- libatsc.la \
+ libgnuradio-atsc-qa.la \
+ libgnuradio-atsc.la \
$(CPPUNIT_LIBS)
# ------------------------------------------------------------------------
@@ -203,6 +207,7 @@ test_atsci_LDADD = \
CLEANFILES = atsci_viterbi_mux.cc atsci_viterbi_gen$(EXEEXT)
+if PYTHON
# ------------------------------------------------------------------------
# This is the swig-ish part of the Makefile.
# It builds the atsc module which we'll load into python
@@ -220,14 +225,13 @@ atsc_pythondir_category = \
# additional libraries for linking with the SWIG-generated library
atsc_la_swig_libadd = \
- libatsc.la
+ libgnuradio-atsc.la
include $(top_srcdir)/Makefile.swig
# add some of the variables generated inside the Makefile.swig.gen
-BUILT_SOURCES = \
- atsci_viterbi_mux.cc \
- $(swig_built_sources)
+BUILT_SOURCES += $(swig_built_sources)
# Do not distribute the output of SWIG
no_dist_files = $(swig_built_sources)
+endif