summaryrefslogtreecommitdiff
path: root/gnuradio-examples/c++/hier/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2006-12-12 20:00:39 +0000
committerjcorgan2006-12-12 20:00:39 +0000
commit76ed4c2fea5f59bfe02bbbb17754ef7eda44feca (patch)
treec30952925ea02e52f137e1e7f4da658629994936 /gnuradio-examples/c++/hier/Makefile.am
parent5de36fac220305307d6fb64eabe6f417a26c0982 (diff)
downloadgnuradio-76ed4c2fea5f59bfe02bbbb17754ef7eda44feca.tar.gz
gnuradio-76ed4c2fea5f59bfe02bbbb17754ef7eda44feca.tar.bz2
gnuradio-76ed4c2fea5f59bfe02bbbb17754ef7eda44feca.zip
Merge jcorgan/hier developer branch into trunk. Enables creation of true hierarchical blocks, from either C++ or Python, as well as creating pure C++ gnuradio applications. EXPERIMENTAL.
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@4070 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gnuradio-examples/c++/hier/Makefile.am')
-rw-r--r--gnuradio-examples/c++/hier/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnuradio-examples/c++/hier/Makefile.am b/gnuradio-examples/c++/hier/Makefile.am
new file mode 100644
index 000000000..f9d341eb7
--- /dev/null
+++ b/gnuradio-examples/c++/hier/Makefile.am
@@ -0,0 +1,56 @@
+#
+# Copyright 2006 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+# For compiling within the GNU Radio build tree
+INCLUDES=$(STD_DEFINES_AND_INCLUDES) \
+ -I$(top_srcdir)/gr-audio-alsa/src
+
+GR_AUDIO_ALSA_LIBS=$(top_builddir)/gr-audio-alsa/src/libgr_audio_alsa.la
+
+# For compiling outside the tree, these are the usual
+# INCLUDES = -I/usr/local/include -I/usr/local/include/gnuradio
+# GNURADIO_CORE_LIBS = -lgnuradio-core
+# GR_AUDIO_ALSA_LIBS = -lgr_audio_alsa
+
+noinst_PROGRAMS = dialtone
+
+noinst_HEADERS = \
+ dialtone.h \
+ sink.h \
+ source.h \
+ siggen.h \
+ output.h
+
+dialtone_SOURCES = \
+ dialtone.cc \
+ source.cc \
+ sink.cc \
+ siggen.cc \
+ output.cc \
+ main.cc
+
+dialtone_LDADD = \
+ $(GNURADIO_CORE_LIBS) \
+ $(GR_AUDIO_ALSA_LIBS)
+
+MOSTLYCLEANFILES = *~