summaryrefslogtreecommitdiff
path: root/gnuradio-core/src/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum2011-07-20 19:04:32 -0700
committerJosh Blum2011-07-20 19:04:32 -0700
commitaccb9f2fe8fd8f6a1e114adac5b15304b0e0012d (patch)
tree09ca98093b2555464265d64fd495fed6102159b4 /gnuradio-core/src/tests/CMakeLists.txt
parentf914499f4a96fe69ab9cd8dba48f8e3bfc7a54e5 (diff)
downloadgnuradio-accb9f2fe8fd8f6a1e114adac5b15304b0e0012d.tar.gz
gnuradio-accb9f2fe8fd8f6a1e114adac5b15304b0e0012d.tar.bz2
gnuradio-accb9f2fe8fd8f6a1e114adac5b15304b0e0012d.zip
gr: squashed cmakelists.txt into one commit
Diffstat (limited to 'gnuradio-core/src/tests/CMakeLists.txt')
-rw-r--r--gnuradio-core/src/tests/CMakeLists.txt71
1 files changed, 71 insertions, 0 deletions
diff --git a/gnuradio-core/src/tests/CMakeLists.txt b/gnuradio-core/src/tests/CMakeLists.txt
new file mode 100644
index 000000000..46f9e630d
--- /dev/null
+++ b/gnuradio-core/src/tests/CMakeLists.txt
@@ -0,0 +1,71 @@
+# Copyright 2010-2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+INCLUDE(GrMiscUtils) #check n def
+GR_CHECK_HDR_N_DEF(sys/resource.h HAVE_SYS_RESOURCE_H)
+
+ADD_DEFINITIONS(${GR_COMMON_FLAGS_AND_DEFINES})
+
+########################################################################
+# Setup the include and linker paths
+########################################################################
+INCLUDE_DIRECTORIES(${GRUEL_INCLUDE_DIRS})
+INCLUDE_DIRECTORIES(${GNURADIO_CORE_INCLUDE_DIRS})
+
+INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
+LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
+
+INCLUDE_DIRECTORIES(${CPPUNIT_INCLUDE_DIRS})
+LINK_DIRECTORIES(${CPPUNIT_LIBRARY_DIRS})
+
+########################################################################
+# Build benchmarks and non-registered tests
+########################################################################
+SET(tests_not_run #single source per test
+ benchmark_dotprod_fff.cc
+ benchmark_dotprod_fsf.cc
+ benchmark_dotprod_ccf.cc
+ benchmark_dotprod_fcc.cc
+ benchmark_dotprod_scc.cc
+ benchmark_dotprod_ccc.cc
+ benchmark_nco.cc
+ benchmark_vco.cc
+ test_runtime.cc
+ test_general.cc
+ test_filter.cc
+ #test_atsc.cc
+ test_vmcircbuf.cc
+)
+
+FOREACH(test_not_run_src ${tests_not_run})
+ GET_FILENAME_COMPONENT(name ${test_not_run_src} NAME_WE)
+ ADD_EXECUTABLE(${name} ${test_not_run_src})
+ TARGET_LINK_LIBRARIES(${name} test-gnuradio-core)
+ENDFOREACH(test_not_run_src)
+
+########################################################################
+# Build the test-all test to end all tests
+# Set the test environment so the build libs will be found under MSVC.
+########################################################################
+INCLUDE(GrTest)
+SET(GR_TEST_TARGET_DEPS gruel gnuradio-core test-gnuradio-core)
+ADD_EXECUTABLE(gr_core_test_all test_all.cc)
+TARGET_LINK_LIBRARIES(gr_core_test_all test-gnuradio-core)
+GR_ADD_TEST(gr-core-test-all gr_core_test_all)