summaryrefslogtreecommitdiff
path: root/gnuradio-core/src/lib/swig/Makefile.am
diff options
context:
space:
mode:
authorRob Savoye2010-11-01 16:05:08 -0600
committerEric Blossom2010-11-10 12:15:43 -0800
commitf81c5677a40cc538ee7631d02aa24602d571ffb8 (patch)
tree7d6d62daf55cabf670b30d34502decb82de80ca8 /gnuradio-core/src/lib/swig/Makefile.am
parent08e6b7c1e72ba6aa75a025e114995de40d7f112f (diff)
downloadgnuradio-f81c5677a40cc538ee7631d02aa24602d571ffb8.tar.gz
gnuradio-f81c5677a40cc538ee7631d02aa24602d571ffb8.tar.bz2
gnuradio-f81c5677a40cc538ee7631d02aa24602d571ffb8.zip
add script names to swig_built_sources, not BUILT_SOURCES. Clean the generated files than now live in subdirectories.
Diffstat (limited to 'gnuradio-core/src/lib/swig/Makefile.am')
-rw-r--r--gnuradio-core/src/lib/swig/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnuradio-core/src/lib/swig/Makefile.am b/gnuradio-core/src/lib/swig/Makefile.am
index 01a5318ec..54cbebeb1 100644
--- a/gnuradio-core/src/lib/swig/Makefile.am
+++ b/gnuradio-core/src/lib/swig/Makefile.am
@@ -23,9 +23,10 @@ include $(top_srcdir)/Makefile.common
include $(top_srcdir)/Makefile.swig
BUILT_SOURCES = $(grinclude_HEADERS) $(swig_built_sources)
-CLEANFILES = python/gnuradio*
+
+CLEANFILES = python/*.cc python/*.h
if GUILE
-CLEANFILES += guile/gnuradio*
+CLEANFILES += guile/*.cc gnuradio/*.scm
endif
# ----------------------------------------------------------------
@@ -111,15 +112,14 @@ gnuradio_core_hier_la_swig_libadd = $(GNURADIO_CORE_LA)
# include the SWIG-generated .h files in the BUILT SOURCES, since they
# aren't by default when using Makefile.swig; order doesn't matter.
PYTHON_GEN = $(foreach HFILE,$(TOP_SWIG_IFILES), $(subst .i,.py,$(HFILE)))
-#BUILT_SOURCES += $(foreach HFILE,$(PYTHON_GEN), $(subst gnuradio,python/gnuradio,$(HFILE)))
-BUILT_SOURCES += $(PYTHON_GEN)
+swig_built_sources += $(PYTHON_GEN)
endif # end of if python
if GUILE
-GUILE_GEN = $(foreach HFILE,$(TOP_SWIG_IFILES), $(patsubst %.i,%.scm,$(HFILE)))
-#GUILE_GEN = $(foreach HFILE,$(TOP_SWIG_IFILES), $(patsubst %.i,gnuradio/%.scm,$(HFILE)))
-# BUILT_SOURCES += $(foreach HFILE,$(GUILE_GEN), $(subst gnuradio,guile/gnuradio,$(HFILE)))
-BUILT_SOURCES += $(GUILE_GEN)
+#GUILE_GEN = $(foreach HFILE,$(TOP_SWIG_IFILES), $(patsubst %.i,%.scm,$(HFILE)))
+GUILE_GEN = $(foreach HFILE,$(TOP_SWIG_IFILES), $(patsubst %.i,gnuradio/%.scm,$(HFILE)))
+# GUILE_GEN_STAMPS = $(filter %.scm,$(TOP_SWIG_IFILES))
+swig_built_sources += $(GUILE_GEN)
endif
# Do not distribute the output of SWIG