summaryrefslogtreecommitdiff
path: root/gnuradio-core/src/lib/swig/Makefile.am
diff options
context:
space:
mode:
authorRob Savoye2010-10-13 22:27:08 -0600
committerEric Blossom2010-11-10 12:10:44 -0800
commit29fef37cdee9eced2ff7c6ff44da2e8e8fa88aa7 (patch)
tree8f4b18ec6e14a1df8d381ea385c57445fc373a21 /gnuradio-core/src/lib/swig/Makefile.am
parent3e970ae219f60f1bf38497cd9fbacb3cc5791d0c (diff)
downloadgnuradio-29fef37cdee9eced2ff7c6ff44da2e8e8fa88aa7.tar.gz
gnuradio-29fef37cdee9eced2ff7c6ff44da2e8e8fa88aa7.tar.bz2
gnuradio-29fef37cdee9eced2ff7c6ff44da2e8e8fa88aa7.zip
split out _SOURCES into separate values for the different scripting languages.
Diffstat (limited to 'gnuradio-core/src/lib/swig/Makefile.am')
-rw-r--r--gnuradio-core/src/lib/swig/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnuradio-core/src/lib/swig/Makefile.am b/gnuradio-core/src/lib/swig/Makefile.am
index 1a50b8c8e..afd6ef268 100644
--- a/gnuradio-core/src/lib/swig/Makefile.am
+++ b/gnuradio-core/src/lib/swig/Makefile.am
@@ -32,6 +32,7 @@ swiginclude_HEADERS = \
gnuradio.i \
gr_swig_block_magic.i \
gr_shared_ptr.i
+# std_complex.i
# special install for this top-level Python script which includes all
# of the split Python libraries.
@@ -88,7 +89,7 @@ include $(top_srcdir)/Makefile.swig
# include the SWIG-generated .h files in the BUILT SOURCES, since they
# aren't by default when using Makefile.swig; order doesn't matter.
-BUILT_SOURCES = \
+PYTHON_GEN = \
gnuradio_swig_py_runtime.h \
gnuradio_swig_py_general.h \
gnuradio_swig_py_gengen.h \
@@ -98,6 +99,15 @@ BUILT_SOURCES = \
$(grinclude_HEADERS) \
$(swig_built_sources)
+BUILT_GUILE = \
+ $(grinclude_HEADERS) \
+ $(swig_built_sources)
+
+BUILT_SOURCES = $(PYTHON_GEN)
+if GUILE
+BUILT_SOURCES += $(BUILT_GUILE)
+endif
+
# Do not distribute the output of SWIG
no_dist_files = $(swig_built_sources)
-endif
+endif # end of if python