summaryrefslogtreecommitdiff
path: root/gnuradio-core/src/lib/swig/Makefile.am
diff options
context:
space:
mode:
authorTom Rondeau2011-11-28 01:11:27 -0500
committerTom Rondeau2011-11-28 01:11:27 -0500
commit0408e48c26bfae60d4973e1f1128ac419d6268a2 (patch)
tree7eeb698b7e6b143af5f4b2128283afc1e8928462 /gnuradio-core/src/lib/swig/Makefile.am
parente173b0746bf10d9bb03c781f2567a5a51d6f6ebd (diff)
downloadgnuradio-0408e48c26bfae60d4973e1f1128ac419d6268a2.tar.gz
gnuradio-0408e48c26bfae60d4973e1f1128ac419d6268a2.tar.bz2
gnuradio-0408e48c26bfae60d4973e1f1128ac419d6268a2.zip
docs: installing generated _doc.i files under autotools.
Diffstat (limited to 'gnuradio-core/src/lib/swig/Makefile.am')
-rw-r--r--gnuradio-core/src/lib/swig/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnuradio-core/src/lib/swig/Makefile.am b/gnuradio-core/src/lib/swig/Makefile.am
index 162285017..0a3234dd6 100644
--- a/gnuradio-core/src/lib/swig/Makefile.am
+++ b/gnuradio-core/src/lib/swig/Makefile.am
@@ -49,12 +49,15 @@ TOP_SWIG_DOC_IFILES = \
runtime_swig_doc.i
-BUILT_SOURCES = \
+BUILT_SOURCES += \
$(TOP_SWIG_DOC_IFILES)
-$(BUILT_SOURCES):
+$(TOP_SWIG_DOC_IFILES):
`echo "" > $@`
+install-data-local:
+ cp -p $(TOP_SWIG_DOC_IFILES) $(swigincludedir)
+
# SWIG headers get installed in ${prefix}/include/gnuradio/swig
swiginclude_HEADERS = \
gnuradio.i \