summaryrefslogtreecommitdiff
path: root/gnuradio-core/src/lib/runtime/Makefile.am
diff options
context:
space:
mode:
authorJohnathan Corgan2009-08-01 09:43:02 -0700
committerEric Blossom2009-08-13 21:40:08 -0700
commitf67c4ff12f19490d2aeab7ff0fbe0484195037f0 (patch)
tree33c9c2f4931c46a8e4f97bba7977189f3c7e448e /gnuradio-core/src/lib/runtime/Makefile.am
parentf15982950e4674f0cad53d25d36409253661af34 (diff)
downloadgnuradio-f67c4ff12f19490d2aeab7ff0fbe0484195037f0.tar.gz
gnuradio-f67c4ff12f19490d2aeab7ff0fbe0484195037f0.tar.bz2
gnuradio-f67c4ff12f19490d2aeab7ff0fbe0484195037f0.zip
Added gr_msg_accepter class.
gr_msg_accepter derives from gruel::msg_accepter_msgq and will implement in its post() a notification of the destination block thread that a message is pending. Passes distcheck.
Diffstat (limited to 'gnuradio-core/src/lib/runtime/Makefile.am')
-rw-r--r--gnuradio-core/src/lib/runtime/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnuradio-core/src/lib/runtime/Makefile.am b/gnuradio-core/src/lib/runtime/Makefile.am
index 14ab464ad..b0e804277 100644
--- a/gnuradio-core/src/lib/runtime/Makefile.am
+++ b/gnuradio-core/src/lib/runtime/Makefile.am
@@ -44,6 +44,7 @@ libruntime_la_SOURCES = \
gr_io_signature.cc \
gr_local_sighandler.cc \
gr_message.cc \
+ gr_msg_accepter.cc \
gr_msg_handler.cc \
gr_msg_queue.cc \
gr_pagesize.cc \
@@ -96,6 +97,7 @@ grinclude_HEADERS = \
gr_io_signature.h \
gr_local_sighandler.h \
gr_message.h \
+ gr_msg_accepter.h \
gr_msg_handler.h \
gr_msg_queue.h \
gr_pagesize.h \