summaryrefslogtreecommitdiff
path: root/gnuradio-core/src/lib/runtime/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2006-08-03 04:51:51 +0000
committerjcorgan2006-08-03 04:51:51 +0000
commit5d69a524f81f234b3fbc41d49ba18d6f6886baba (patch)
treeb71312bf7f1e8d10fef0f3ac6f28784065e73e72 /gnuradio-core/src/lib/runtime/Makefile.am
downloadgnuradio-5d69a524f81f234b3fbc41d49ba18d6f6886baba.tar.gz
gnuradio-5d69a524f81f234b3fbc41d49ba18d6f6886baba.tar.bz2
gnuradio-5d69a524f81f234b3fbc41d49ba18d6f6886baba.zip
Houston, we have a trunk.
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@3122 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gnuradio-core/src/lib/runtime/Makefile.am')
-rw-r--r--gnuradio-core/src/lib/runtime/Makefile.am109
1 files changed, 109 insertions, 0 deletions
diff --git a/gnuradio-core/src/lib/runtime/Makefile.am b/gnuradio-core/src/lib/runtime/Makefile.am
new file mode 100644
index 000000000..7ee94ba1b
--- /dev/null
+++ b/gnuradio-core/src/lib/runtime/Makefile.am
@@ -0,0 +1,109 @@
+#
+# Copyright 2003,2004 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+# Boston, MA 02111-1307, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+INCLUDES = $(STD_DEFINES_AND_INCLUDES) $(CPPUNIT_INCLUDES)
+
+noinst_LTLIBRARIES = libruntime.la libruntime-qa.la
+
+libruntime_la_LIBADD = \
+ $(SHM_OPEN_LIBS)
+
+
+libruntime_la_SOURCES = \
+ gr_block.cc \
+ gr_block_detail.cc \
+ gr_buffer.cc \
+ gr_dispatcher.cc \
+ gr_error_handler.cc \
+ gr_io_signature.cc \
+ gr_local_sighandler.cc \
+ gr_message.cc \
+ gr_msg_handler.cc \
+ gr_msg_queue.cc \
+ gr_pagesize.cc \
+ gr_preferences.cc \
+ gr_realtime.cc \
+ gr_single_threaded_scheduler.cc \
+ gr_tmp_path.cc \
+ gr_vmcircbuf.cc \
+ gr_vmcircbuf_mmap_shm_open.cc \
+ gr_vmcircbuf_mmap_tmpfile.cc \
+ gr_vmcircbuf_createfilemapping.cc \
+ gr_vmcircbuf_sysv_shm.cc \
+ gr_select_handler.cc
+
+libruntime_qa_la_SOURCES = \
+ qa_gr_block.cc \
+ qa_gr_buffer.cc \
+ qa_gr_io_signature.cc \
+ qa_gr_vmcircbuf.cc \
+ qa_runtime.cc
+
+grinclude_HEADERS = \
+ gr_block.h \
+ gr_block_detail.h \
+ gr_buffer.h \
+ gr_complex.h \
+ gr_dispatcher.h \
+ gr_error_handler.h \
+ gr_io_signature.h \
+ gr_local_sighandler.h \
+ gr_message.h \
+ gr_msg_handler.h \
+ gr_msg_queue.h \
+ gr_pagesize.h \
+ gr_preferences.h \
+ gr_realtime.h \
+ gr_runtime.h \
+ gr_select_handler.h \
+ gr_single_threaded_scheduler.h \
+ gr_timer.h \
+ gr_tmp_path.h \
+ gr_types.h \
+ gr_vmcircbuf.h
+
+noinst_HEADERS = \
+ gr_vmcircbuf_mmap_shm_open.h \
+ gr_vmcircbuf_mmap_tmpfile.h \
+ gr_vmcircbuf_sysv_shm.h \
+ gr_vmcircbuf_createfilemapping.h \
+ qa_gr_block.h \
+ qa_gr_buffer.h \
+ qa_gr_io_signature.h \
+ qa_gr_vmcircbuf.h \
+ qa_runtime.h
+
+swiginclude_HEADERS = \
+ gr_block.i \
+ gr_block_detail.i \
+ gr_buffer.i \
+ gr_dispatcher.i \
+ gr_error_handler.i \
+ gr_io_signature.i \
+ gr_message.i \
+ gr_msg_handler.i \
+ gr_msg_queue.i \
+ gr_realtime.i \
+ gr_single_threaded_scheduler.i \
+ gr_swig_block_magic.i \
+ runtime.i