summaryrefslogtreecommitdiff
path: root/gnuradio-core/src/lib/runtime/Makefile.am
diff options
context:
space:
mode:
authoreb2008-07-09 18:59:37 +0000
committereb2008-07-09 18:59:37 +0000
commit395e1fa650428899dee0f123cb7bf432732280c5 (patch)
treed84e105db26cfcca921c7446f001b31aef042984 /gnuradio-core/src/lib/runtime/Makefile.am
parent73a2e8ac45347d1c1a12518557fb641dff3233b5 (diff)
downloadgnuradio-395e1fa650428899dee0f123cb7bf432732280c5.tar.gz
gnuradio-395e1fa650428899dee0f123cb7bf432732280c5.tar.bz2
gnuradio-395e1fa650428899dee0f123cb7bf432732280c5.zip
Merged jcorgan/ptrfix -r8827:8843 into the trunk.
Fix that allows C++ classes derived from gr_hier_block2 to use the new self() method to get a magic object that can be passed to connect or disconnect to refer to their own inputs and outputs. Note that the constructor wrapper of all classes derived from gr_hier_block2 (and thus gr_top_block too) MUST USE the new gnuradio::get_initial_sptr function to get the initial shared pointer. gnuradio::get_initial_sptr works on all block types, and should be used in all new code. See qa_gr_hier_block2_derived.{h,cc} for an example. git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@8844 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gnuradio-core/src/lib/runtime/Makefile.am')
-rw-r--r--gnuradio-core/src/lib/runtime/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnuradio-core/src/lib/runtime/Makefile.am b/gnuradio-core/src/lib/runtime/Makefile.am
index 0463581c7..550031b94 100644
--- a/gnuradio-core/src/lib/runtime/Makefile.am
+++ b/gnuradio-core/src/lib/runtime/Makefile.am
@@ -50,6 +50,7 @@ libruntime_la_SOURCES = \
gr_realtime.cc \
gr_scheduler_thread.cc \
gr_single_threaded_scheduler.cc \
+ gr_sptr_magic.cc \
gr_sync_block.cc \
gr_sync_decimator.cc \
gr_sync_interpolator.cc \
@@ -67,6 +68,7 @@ libruntime_la_SOURCES = \
libruntime_qa_la_SOURCES = \
qa_gr_block.cc \
qa_gr_hier_block2.cc \
+ qa_gr_hier_block2_derived.cc \
qa_gr_buffer.cc \
qa_gr_flowgraph.cc \
qa_gr_top_block.cc \
@@ -98,6 +100,7 @@ grinclude_HEADERS = \
gr_scheduler_thread.h \
gr_select_handler.h \
gr_single_threaded_scheduler.h \
+ gr_sptr_magic.h \
gr_sync_block.h \
gr_sync_decimator.h \
gr_sync_interpolator.h \
@@ -117,6 +120,7 @@ noinst_HEADERS = \
qa_gr_block.h \
qa_gr_flowgraph.h \
qa_gr_hier_block2.h \
+ qa_gr_hier_block2_derived.h \
qa_gr_buffer.h \
qa_gr_io_signature.h \
qa_gr_top_block.h \