summaryrefslogtreecommitdiff
path: root/gnuradio-core/src/lib/reed-solomon/Makefile.am
diff options
context:
space:
mode:
authorJohnathan Corgan2011-12-08 13:48:48 -0800
committerJohnathan Corgan2011-12-08 13:48:48 -0800
commit00420d32081d8252bb37142b2be19a8a7c4dc4c4 (patch)
tree12c6bf83f01ffc4eff010102090bb687a1233558 /gnuradio-core/src/lib/reed-solomon/Makefile.am
parentf52be4a8f0fa203ed206d0e0afc099856eb5bd03 (diff)
downloadgnuradio-00420d32081d8252bb37142b2be19a8a7c4dc4c4.tar.gz
gnuradio-00420d32081d8252bb37142b2be19a8a7c4dc4c4.tar.bz2
gnuradio-00420d32081d8252bb37142b2be19a8a7c4dc4c4.zip
Removed autotools, gr-waveform, some cleanup
Nick Foster owes Nick Corgan a six-pack of beer!
Diffstat (limited to 'gnuradio-core/src/lib/reed-solomon/Makefile.am')
-rw-r--r--gnuradio-core/src/lib/reed-solomon/Makefile.am55
1 files changed, 0 insertions, 55 deletions
diff --git a/gnuradio-core/src/lib/reed-solomon/Makefile.am b/gnuradio-core/src/lib/reed-solomon/Makefile.am
deleted file mode 100644
index 5548f4280..000000000
--- a/gnuradio-core/src/lib/reed-solomon/Makefile.am
+++ /dev/null
@@ -1,55 +0,0 @@
-#
-# Copyright 2002,2008 Free Software Foundation, Inc.
-#
-# This file is part of GNU Radio
-#
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-#
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING. If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-#
-
-include $(top_srcdir)/Makefile.common
-
-# Note, this Makefile.am only builds the char versions of the reed soloman routines.
-# If you need the int versions too, please figure out how to add them *cleanly* to
-# this Makefile.am.
-
-AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(CPPUNIT_INCLUDES) $(WITH_INCLUDES)
-
-TESTS = rstest
-
-EXTRA_DIST += \
- README.karn
-
-noinst_LTLIBRARIES = librs.la
-
-noinst_PROGRAMS = \
- rstest
-
-librs_la_SOURCES = \
- encode_rs.c \
- decode_rs.c \
- init_rs.c
-
-grinclude_HEADERS = \
- rs.h
-
-noinst_HEADERS = \
- ccsds.h \
- char.h \
- int.h \
- fixed.h
-
-rstest_SOURCES = rstest.c exercise.c
-rstest_LDADD = librs.la