summaryrefslogtreecommitdiff
path: root/gnuradio-core/src/lib/io/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2006-08-03 04:51:51 +0000
committerjcorgan2006-08-03 04:51:51 +0000
commit5d69a524f81f234b3fbc41d49ba18d6f6886baba (patch)
treeb71312bf7f1e8d10fef0f3ac6f28784065e73e72 /gnuradio-core/src/lib/io/Makefile.am
downloadgnuradio-5d69a524f81f234b3fbc41d49ba18d6f6886baba.tar.gz
gnuradio-5d69a524f81f234b3fbc41d49ba18d6f6886baba.tar.bz2
gnuradio-5d69a524f81f234b3fbc41d49ba18d6f6886baba.zip
Houston, we have a trunk.
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@3122 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gnuradio-core/src/lib/io/Makefile.am')
-rw-r--r--gnuradio-core/src/lib/io/Makefile.am96
1 files changed, 96 insertions, 0 deletions
diff --git a/gnuradio-core/src/lib/io/Makefile.am b/gnuradio-core/src/lib/io/Makefile.am
new file mode 100644
index 000000000..e390e1344
--- /dev/null
+++ b/gnuradio-core/src/lib/io/Makefile.am
@@ -0,0 +1,96 @@
+#
+# Copyright 2001,2003,2004 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+# Boston, MA 02111-1307, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+
+INCLUDES = $(STD_DEFINES_AND_INCLUDES)
+
+noinst_LTLIBRARIES = libio.la
+
+
+libio_la_SOURCES = \
+ gr_file_sink.cc \
+ gr_file_source.cc \
+ gr_file_descriptor_sink.cc \
+ gr_file_descriptor_source.cc \
+ gr_message_sink.cc \
+ gr_message_source.cc \
+ gr_oscope_guts.cc \
+ gr_oscope_sink_f.cc \
+ gr_oscope_sink_x.cc \
+ gri_logger.cc \
+ i2c.cc \
+ i2c_bitbang.cc \
+ i2c_bbio.cc \
+ i2c_bbio_pp.cc \
+ microtune_4702.cc \
+ microtune_4937.cc \
+ microtune_4702_eval_board.cc \
+ microtune_4937_eval_board.cc \
+ microtune_xxxx.cc \
+ microtune_xxxx_eval_board.cc \
+ ppio.cc \
+ ppio_ppdev.cc \
+ sdr_1000.cc
+
+grinclude_HEADERS = \
+ gr_file_sink.h \
+ gr_file_source.h \
+ gr_file_descriptor_sink.h \
+ gr_file_descriptor_source.h \
+ gr_message_sink.h \
+ gr_message_source.h \
+ gr_oscope_guts.h \
+ gr_oscope_sink_f.h \
+ gr_oscope_sink_x.h \
+ gr_trigger_mode.h \
+ gri_logger.h \
+ i2c.h \
+ i2c_bitbang.h \
+ i2c_bbio.h \
+ i2c_bbio_pp.h \
+ microtune_4702.h \
+ microtune_4937.h \
+ microtune_4702_eval_board.h \
+ microtune_4937_eval_board.h \
+ microtune_eval_board_defs.h \
+ microtune_xxxx.h \
+ microtune_xxxx_eval_board.h \
+ ppio.h \
+ ppio_ppdev.h \
+ sdr_1000.h
+
+
+swiginclude_HEADERS = \
+ io.i \
+ gr_file_sink.i \
+ gr_file_source.i \
+ gr_file_descriptor_sink.i \
+ gr_file_descriptor_source.i \
+ gr_message_sink.i \
+ gr_message_source.i \
+ gr_oscope_sink.i \
+ microtune_xxxx_eval_board.i \
+ microtune_4702_eval_board.i \
+ microtune_4937_eval_board.i \
+ ppio.i \
+ sdr_1000.i