summaryrefslogtreecommitdiff
path: root/gnuradio-core/src/lib/io/Makefile.am
diff options
context:
space:
mode:
authorEric Blossom2010-11-10 18:21:50 -0800
committerEric Blossom2010-11-10 18:21:50 -0800
commit5783b693279b6c64ef800f6e8294ec68a2869b29 (patch)
treecabada99ccafc7eaf1bf8fd18685058343cac5e8 /gnuradio-core/src/lib/io/Makefile.am
parentfa9eeb2aab040a3c74da639233ba8f9a585b0455 (diff)
downloadgnuradio-5783b693279b6c64ef800f6e8294ec68a2869b29.tar.gz
gnuradio-5783b693279b6c64ef800f6e8294ec68a2869b29.tar.bz2
gnuradio-5783b693279b6c64ef800f6e8294ec68a2869b29.zip
Revert "add the .i files as dependencies"
This reverts commit f43d2a4759e0ecd6519c0ac0aa4afbc54e70ea65. The dependencies doesn't make any sense. There's an attempt to run sed on files that haven't been generated yet.
Diffstat (limited to 'gnuradio-core/src/lib/io/Makefile.am')
-rw-r--r--gnuradio-core/src/lib/io/Makefile.am14
1 files changed, 0 insertions, 14 deletions
diff --git a/gnuradio-core/src/lib/io/Makefile.am b/gnuradio-core/src/lib/io/Makefile.am
index 0ab9ac135..c52554645 100644
--- a/gnuradio-core/src/lib/io/Makefile.am
+++ b/gnuradio-core/src/lib/io/Makefile.am
@@ -113,17 +113,3 @@ swiginclude_HEADERS = \
gr_wavfile_source.i \
gr_wavfile_sink.i
endif
-
-# Produce a list of the file names with the .cc stripped off
-files = $(foreach HFILE,$(libio_la_SOURCES), $(patsubst %.cc,%,$(HFILE)))
-
-# All .lo files depend on the .i file of the same name
-define template
--include $(DEPDIR)/$(1).d
-$(DEPDIR)/$(1).d:
- @echo "$(1).lo: \\" > $(DEPDIR)/$(1).d
- @cat ../swig/guile/gnuradio_core_io.Std | sed -e '1d;' >> $(DEPDIR)/$(1).d
-endef
-
-# Generate all the dependencies at runtime
-$(foreach prog,$(files),$(eval $(call template,$(prog))))