summaryrefslogtreecommitdiff
path: root/gnuradio-core/src/lib/gengen/Makefile.am
diff options
context:
space:
mode:
authorJohnathan Corgan2011-03-16 08:18:30 -0700
committerJohnathan Corgan2011-03-16 08:18:30 -0700
commit4cd06fadac972d4cac559c15488bc39823063afe (patch)
tree6fe57896bc216d8c9e672194f2e4e0e75aedb645 /gnuradio-core/src/lib/gengen/Makefile.am
parent4ad736e21f45f64fd616bb53f54e45e1c63e7330 (diff)
parent1d70ed2bd928d52a383e688949cc7f747dd584fa (diff)
downloadgnuradio-4cd06fadac972d4cac559c15488bc39823063afe.tar.gz
gnuradio-4cd06fadac972d4cac559c15488bc39823063afe.tar.bz2
gnuradio-4cd06fadac972d4cac559c15488bc39823063afe.zip
Merge remote branch 'gnuradio/next'
* gnuradio/next: (806 commits) gruel: added missing ignores gruel: fixed swig interface file to dereference pmt_t. qtgui: fix distcheck error gruel: fixing structure. Passes make check. gruel: SWIGing Gruel into Python to access PMTs. gnuradio-examples: add C++ audio examples using new gr-audio created gruel/attributes.h to house compiler specific attribute macros audio: remove obsoleted individual top-level components gr-audio: added README and default config fix volk: simplify the get new method for the aligned pool grc: moved all usrp1 and usrp2 stuff out of grc and into gr-usrp*/grc grc: swap store the subprocess object rather than the pid when executing qtgui: removed python directory that was added, never used uhd: use %ignore to hide warnings and fix errors Added/updated ignore files. Fixing gr_filter_design program to import from gnuradio Python package. audio: high prio for platform specific audio osx audio: added windows and osx audio source files audio: added config checks for other audios, added jack and port audio: make prefs look like old audio, removed old audio.py ...
Diffstat (limited to 'gnuradio-core/src/lib/gengen/Makefile.am')
-rw-r--r--gnuradio-core/src/lib/gengen/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnuradio-core/src/lib/gengen/Makefile.am b/gnuradio-core/src/lib/gengen/Makefile.am
index 4978ad1c5..5fbb6f52c 100644
--- a/gnuradio-core/src/lib/gengen/Makefile.am
+++ b/gnuradio-core/src/lib/gengen/Makefile.am
@@ -115,7 +115,7 @@ core_generator = \
gr_moving_average_XX.i.t
# Source built by Python into $(builddir)
-BUILT_SOURCES = \
+BUILT_SOURCES += \
$(GENERATED_H) \
$(GENERATED_I) \
$(GENERATED_CC) \
@@ -123,7 +123,7 @@ BUILT_SOURCES = \
# ----------------------------------------------------------------
-EXTRA_DIST = \
+EXTRA_DIST += \
$(core_generator)
libgengen_la_SOURCES = \
@@ -135,13 +135,11 @@ grinclude_HEADERS = \
gr_noise_type.h \
gr_sig_source_waveform.h
-if PYTHON
swiginclude_HEADERS = \
$(GENERATED_I) \
gr_endianness.i \
gengen.i \
gengen_generated.i
-endif
# Do creation and inclusion of other Makefiles last