summaryrefslogtreecommitdiff
path: root/gnuradio-core/src/lib/Makefile.am
diff options
context:
space:
mode:
authoreb2007-01-13 04:14:56 +0000
committereb2007-01-13 04:14:56 +0000
commitcbe1628f2eb1a1a3c8b0b96a3b1334a039074def (patch)
tree1d551091f8eac7c5381990946e6a5183191905b6 /gnuradio-core/src/lib/Makefile.am
parent90347f36e4087cb2136096c9f1f43c0cb629dcb0 (diff)
downloadgnuradio-cbe1628f2eb1a1a3c8b0b96a3b1334a039074def.tar.gz
gnuradio-cbe1628f2eb1a1a3c8b0b96a3b1334a039074def.tar.bz2
gnuradio-cbe1628f2eb1a1a3c8b0b96a3b1334a039074def.zip
SWIG compilation speedup! Fixes ticket:9.
Merged -r4203:4254 from eb/swig-split into trunk. This refactors gnuradio_swig_python.{cc,py} into 5 separate .so's These correspond to the runtime, general, filter and io directories, and also includes a new directory, gengen. gengen contains that part of general that was machine generated. This split is arbitrary, but was useful for getting size of the swig generated glue code for general down to about 2MB. In addition, the swig glue is now compiled with -g1 -O1 instead of -g -O2. With this change all the swig code now compiles in about 60% of the time that it used to take. git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@4255 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gnuradio-core/src/lib/Makefile.am')
-rw-r--r--gnuradio-core/src/lib/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnuradio-core/src/lib/Makefile.am b/gnuradio-core/src/lib/Makefile.am
index 05461a05c..96a891700 100644
--- a/gnuradio-core/src/lib/Makefile.am
+++ b/gnuradio-core/src/lib/Makefile.am
@@ -24,7 +24,7 @@ include $(top_srcdir)/Makefile.common
## Process this file with automake to produce Makefile.in
# We've got to build . before swig
-SUBDIRS = missing runtime filter general g72x reed-solomon omnithread io . swig
+SUBDIRS = missing runtime filter general gengen g72x reed-solomon omnithread io . swig
# generate libgnuradio-core.la from the convenience libraries in subdirs
@@ -41,6 +41,7 @@ libgnuradio_core_la_LIBADD = \
filter/libfilter.la \
g72x/libccitt.la \
general/libgeneral.la \
+ gengen/libgengen.la \
io/libio.la \
missing/libmissing.la \
omnithread/libomnithread.la \